summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGeorge Lebl <jirka@5z.com>2002-08-15 19:13:55 +0000
committerGeorge Lebl <jirka@src.gnome.org>2002-08-15 19:13:55 +0000
commitf93e3de07f160c3af88fa6f9fb686cbbe999e5aa (patch)
tree2f6ffa67525a88ffdae870930aa0a149e2d2c84b /Makefile.am
parent7a7f30f536df6cdc951ea2b9eea3e0b183e5ad69 (diff)
downloadgdm-f93e3de07f160c3af88fa6f9fb686cbbe999e5aa.tar.gz
remove some dead code. Ensure euid's in more places. open .xsession-errors
Thu Aug 15 12:04:24 2002 George Lebl <jirka@5z.com> * daemon/gdm.c, daemon/slave.c: remove some dead code. Ensure euid's in more places. open .xsession-errors even on nfs dirs properly. For the Init/PreSession/PostSession scripts always setup the GDM_PARENT_* stuff for Xnest displays. Don't use temp files, but name the temporary auth file by the display name and whack it on server stop. The Init/PreSession/PostSession scripts now execute /<displayname>, if not found then /<hostname>, if not found and XDMCP then /XDMCP, if not found and flexi then /Flexi, and only if none of those are found then /Default. * daemon/errorgui.c: show label and entry in the question dialog, fixes problems when asking for questions during autologin. Also set cursor to pointer. * daemon/slave.c: set cursor to pointer after forking slave. This should fix possible busy cursor stuck after an autologin. * config/PostSession: spelling fix * daemon/verify-pam.c: add extra message for automatic login for standalone conversation thingie. This uses already translated string. * daemon/gdm.c: wait 2 seconds between killing local servers, otherwise things go very very bad on some machines (such as eating my keyboard on mine) * configure.in, Makefile.am, gdm-stop.in: new script to just SIGTERM the gdm binary. Useful for debugging
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6765e57b..33cb5ad4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,11 +14,12 @@ EXTRA_DIST = \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
+ gdm-stop.in \
gdm-restart.in \
gdm-safe-restart.in \
gdmconfig
-sbin_SCRIPTS = gdm-restart gdm-safe-restart gdmconfig
+sbin_SCRIPTS = gdm-stop gdm-restart gdm-safe-restart gdmconfig
install-data-local: gdmsetup-security
if CONSOLE_HELPER