summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJulio M. Merino Vidal <jmmv@NetBSD.org>2006-03-28 23:43:24 +0000
committerBrian Cameron <bcameron@src.gnome.org>2006-03-28 23:43:24 +0000
commit7ad2d48fdf532905a9312d793ec521aa3e0e4212 (patch)
tree4c1753cba1cece7c1825e017a333841987c78fcb /Makefile.am
parent8d4974c0087d5b92ce300ab8b6734e3d986bdd41 (diff)
downloadgdm-7ad2d48fdf532905a9312d793ec521aa3e0e4212.tar.gz
Removed a C99 local variable definition that breaks the build with gcc
006-03-28 Julio M. Merino Vidal <jmmv@NetBSD.org> * daemon/xdmcp.c: Removed a C99 local variable definition that breaks the build with gcc 2.95 (e.g. under NetBSD 1.6). Fixes bug #336368. 2006-03-28 Julio M. Merino Vidal <jmmv@NetBSD.org> * daemon/gdmconfig.c, daemon/server.c: Include sys/resource.h, needed to use setpriority(2) and its associated definitions. Fixes the build under NetBSD, closing bug #336369. 2006-03-28 Julio M. Merino Vidal <jmmv@NetBSD.org> * Makefile.am, README.install, acconfig.h, configure.ac, gdmsetup-security.in, config/Makefile.am, config/Xsession.in, config/gdm.conf.in, daemon/Makefile.am, daemon/gdm.c, daemon/gdm.h, daemon/gdm.in, daemon/gdmconfig.c, daemon/misc.c, daemon/server.c, daemon/slave.c, docs/C/gdm.xml, gui/Makefile.am, gui/gdmphotosetup.c, gui/gdmsetup.c, gui/gdmsetup.desktop.in, gui/greeter/Makefile.am, gui/greeter/gdmthemetester.in, gui/greeter/greeter.c, gui/modules/Makefile.am: Get rid of all EXPANDED_* variables from the build procedure. Directory-related variables must only be expanded from the Makefiles so that they can be easily overriden during the installation phase. Fixes bug #336364.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bd16992e..3522d165 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,10 +31,19 @@ EXTRA_DIST = \
sbin_SCRIPTS = gdm-stop gdm-restart gdm-safe-restart
-install-data-local: gdmsetup-security
if CONSOLE_HELPER
- $(INSTALL_DATA) -D $(srcdir)/gdmsetup-pam $(DESTDIR)$(PAM_PREFIX)/pam.d/gdmsetup
- $(INSTALL_DATA) -D gdmsetup-security $(DESTDIR)$(PAM_PREFIX)/security/console.apps/gdmsetup
+cappsdir = $(PAM_PREFIX)/security/console.apps
+capps_DATA = gdmsetup
+
+CLEANFILES = gdmsetup-security
+gdmsetup: $(srcdir)/gdmsetup-security.in
+ sed -e 's,[@]sbindir[@],$(sbindir),g' <$(srcdir)/gdmsetup-security.in >gdmsetup
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(PAM_PREFIX)/pam.d
+ $(INSTALL_DATA) $(srcdir)/gdmsetup-pam $(DESTDIR)$(PAM_PREFIX)/pam.d/gdmsetup
+else
+install-data-local:
endif
DISTCLEANFILES = \