summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Cameron <Brian.Cameron@Sun.Com>2005-01-28 18:14:38 +0000
committerBrian Cameron <bcameron@src.gnome.org>2005-01-28 18:14:38 +0000
commit6547f64ca7d35aa129694b2693864701e9f67fb0 (patch)
treeb8bab1ecebe9130cd21969ba038541396563a16d /Makefile.am
parent27e927e3073d4e5554cb65017f3e23f200ff2555 (diff)
downloadgdm-6547f64ca7d35aa129694b2693864701e9f67fb0.tar.gz
Added distuninstallcheck_listfiles for the files in /var/scrollkeeper,
Tue Jan 25 17:18:00 2005 Brian Cameron <Brian.Cameron@Sun.Com> * This patch makes gdm2 build with newer versions of the build tools. Previously it was requiring automake-1.4, autoconf-1.4, and clocal-1.4. Better error checking in the newer version caught the following issues: * Makefile.am: Added distuninstallcheck_listfiles for the files in /var/scrollkeeper, which were causing "makedist" to fail. Removed intltool-modules/XML/Parser/Style/OrigTree.pm from EXTRA_DIST since that file isn't required by newer versions of intltool. * omf.make, xmldocs.make: Fixed errors in "makedist". I found a pointer to the fix here: mail.gnome.org/archives/desktop-devel-list/2003-December/msg00587.html * gui/Makefile.am, gui/greeter/themes/circles/Makefile.am, gui/modules/Makefile.am, gui/greeter/themes/happygnome/Makefile.am, config/Makefile.am, gui/greeter/themes/happygnome-list/Makefile.am: Added clean-local and uninstall-hook to fix errors in "makedist". Made sure all *.desktop files are in EXTRA_DIST. * daemon/slave.c: Not related to above patches. Fixed grammar again since we aren't in a string freeze. Sorry for the confusion.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dd253b1d..e5aedc7c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,6 @@ EXTRA_DIST = \
intltool-extract.in \
intltool-merge.in \
intltool-update.in \
- intltool-modules/XML/Parser/Style/OrigTree.pm \
gdm-stop.in \
gdm-restart.in \
gdm-safe-restart.in \
@@ -44,3 +43,5 @@ DISTCLEANFILES = \
intltool-extract \
intltool-merge \
intltool-update
+
+distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'