summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGeorge Lebl <jirka@5z.com>2001-06-05 03:44:29 +0000
committerGeorge Lebl <jirka@src.gnome.org>2001-06-05 03:44:29 +0000
commitab1e11680746f99f8742f8277b22dbbcd12d584c (patch)
tree8fac158043e0d6af5245f82af372a185b8a29ed4 /Makefile.am
parentaa932186daf51118989ddb40d47bfed4d2390b41 (diff)
downloadgdm-ab1e11680746f99f8742f8277b22dbbcd12d584c.tar.gz
remove unused opcode (GDM_STOP)
Sun Jun 03 04:55:49 2001 George Lebl <jirka@5z.com> * daemon/gdm.h: remove unused opcode (GDM_STOP) * daemon/slave.c, gui/gdmlogin.c: On GDM_QUIT the login will make sure to quickly quit and in the slave we no longer kill it to avoid a possible race, also try to avoid other races todo with killing things. Also fclose the greeter channel to avoid a leak. * daemon/gdm.h, daemon/slave.c: get the size of the screen from xinerama and center error dialog stuff.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index ffef8225..7ccfa430 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ EXTRA_DIST = \
gdm.spec \
gdm.spec.in \
gdmconfig-pam \
- gdmconfig-security \
+ gdmconfig-security.in \
xml-i18n-extract.in \
xml-i18n-merge.in \
xml-i18n-update.in \
@@ -14,13 +14,13 @@ EXTRA_DIST = \
sbin_SCRIPTS = gdm-restart
-install-data-local:
+install-data-local: gdmconfig-security
if CONSOLE_HELPER
- $(INSTALL_DATA) -D gdmconfig-pam $(sysconfdir)/pam.d/gdmconfig
- $(INSTALL_DATA) -D gdmconfig-security $(sysconfdir)/security/console.apps/gdmconfig
+ $(INSTALL_DATA) -D gdmconfig-pam @PAM_PREFIX@/pam.d/gdmconfig
+ $(INSTALL_DATA) -D gdmconfig-security @PAM_PREFIX@/security/console.apps/gdmconfig
$(INSTALL_DATA) -m 755 -d $(sbindir)
mv $(bindir)/gdmconfig $(sbindir)
- $(LN_S) @bindir@/consolehelper $(bindir)/gdmconfig
+ $(LN_S) @CONSOLE_HELPER@ $(bindir)/gdmconfig
endif
DISTCLEANFILES = \