summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-03-21 17:08:39 +0000
committerWilliam Jon McCann <mccann@src.gnome.org>2007-03-21 17:08:39 +0000
commitaae779a0c49b2ed689a1b44298c6b0d2d4298c08 (patch)
tree629111aba5bfddee4537cf1ed6f95209ac8c9c91 /common/Makefile.am
parent94b410c4a4f36cd04f1a9ee32d82806e1ba2b573 (diff)
downloadgdm-aae779a0c49b2ed689a1b44298c6b0d2d4298c08.tar.gz
Added new files missed from commit for #355425
2007-03-21 William Jon McCann <mccann@jhu.edu> * common/Makefile.am: * common/gdm-common-config.c: (gdm_common_config_parse_key_string), (gdm_common_config_load), (gdm_common_config_save), (gdm_common_config_get_int), (gdm_common_config_get_translated_string), (gdm_common_config_get_string), (gdm_common_config_get_boolean), (gdm_common_config_set_string), (gdm_common_config_set_boolean), (gdm_common_config_set_int), (gdm_common_config_remove_key): * common/gdm-common-config.h: * common/gdm-common.c: (ve_clearenv), (ve_first_word), (ve_first_word_executable), (ve_get_first_working_command), (ve_rest), (ve_bool_equal), (ve_is_string_in_list), (ve_is_string_in_list_case_no_locale), (ve_find_file_simple), (ve_locale_to_utf8), (ve_locale_from_utf8), (ve_filename_to_utf8), (ve_filename_from_utf8), (ve_strftime), (ve_waitpid_no_signal), (ve_locale_exists), (ve_find_prog_in_path), (ve_is_prog_in_path), (ve_shell_quote_filename): * common/gdm-common.h: * common/ve-signal.c: (ve_signal_prepare), (ve_signal_check), (ve_signal_dispatch), (ve_signal_add), (ve_signal_add_full), (ve_signal_notify), (ve_signal_was_notified), (ve_signal_unnotify): * common/ve-signal.h: Added new files missed from commit for #355425 svn path=/trunk/; revision=4696
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 00000000..63f670e9
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,30 @@
+## Process this file with automake to produce Makefile.in
+
+NULL =
+
+INCLUDES = \
+ -I. \
+ -I.. \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ $(GLIB_CFLAGS)
+
+noinst_LIBRARIES = \
+ libgdmcommon.a \
+ $(null)
+
+libgdmcommon_a_SOURCES = \
+ gdm-common.h \
+ gdm-common.c \
+ gdm-common-config.h \
+ gdm-common-config.c \
+ ve-signal.h \
+ ve-signal.c \
+ $(NULL)
+
+libgdmcommon_ui_a_SOURCES = \
+ $(libgdmcommon_a_SOURCES) \
+ glade-helper.c \
+ glade-helper.h \
+ gdm-common-ui.c \
+ gdm-common-ui.h \
+ $(NULL)