summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2011-06-13 22:10:20 -0400
committerRay Strode <rstrode@redhat.com>2011-06-13 22:10:20 -0400
commit1101f68b4be360310c0e36ecafba022270baae7e (patch)
treec2f87d569c8c23effe653386b1ad6ef1e7cdef06 /common/Makefile.am
parentba5b6b1daf9f995cd0b56cebef602fe7b21b678e (diff)
downloadgdm-1101f68b4be360310c0e36ecafba022270baae7e.tar.gz
common: drop custom marshaller goo
We live in a modern society where phones look like something from Inspector Gadget and signal marshalling is no longer something to waste goo credits on.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am13
1 files changed, 0 insertions, 13 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 03cb46bc..3c2bc71e 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -30,8 +30,6 @@ noinst_LTLIBRARIES = \
BUILT_SOURCES = \
gdm-settings-glue.h \
- gdm-marshal.c \
- gdm-marshal.h \
$(NULL)
gdmdir = $(datadir)/gdm
@@ -54,13 +52,6 @@ gdm_crash_logger_LDADD = $(GTHREAD_LIBS)
gdm-settings-glue.h: gdm-settings.xml Makefile.am
dbus-binding-tool --prefix=gdm_settings --mode=glib-server --output=gdm-settings-glue.h $(srcdir)/gdm-settings.xml
-gdm-marshal.c: gdm-marshal.list
- echo "#include \"gdm-marshal.h\"" > $@ && \
- @GLIB_GENMARSHAL@ $< --prefix=gdm_marshal --body >> $@
-
-gdm-marshal.h: gdm-marshal.list
- @GLIB_GENMARSHAL@ $< --prefix=gdm_marshal --header > $@
-
if MKDTEMP_MISSING
MKDTEMP_FILES = mkdtemp.c mkdtemp.h
else
@@ -98,10 +89,6 @@ libgdmcommon_la_SOURCES = \
$(MKDTEMP_FILES) \
$(NULL)
-nodist_libgdmcommon_la_SOURCES = \
- gdm-marshal.c \
- gdm-marshal.h
-
libgdmcommon_la_CPPFLAGS = \
$(AM_CPPFLAGS) \
$(DISABLE_DEPRECATED_CFLAGS) \