summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <jmccann@redhat.com>2008-07-31 00:31:05 +0000
committerWilliam Jon McCann <mccann@src.gnome.org>2008-07-31 00:31:05 +0000
commit32b914376ff6b6243677ce382af0a3f36e030e6f (patch)
tree026124c2d1abc6b1615030f7e57da8f2d3f21355 /common/Makefile.am
parent3d0975ff2308766d809db5ac788cbc212be53edb (diff)
downloadgdm-32b914376ff6b6243677ce382af0a3f36e030e6f.tar.gz
Wow, that was really broken. Use mkdtemp when available to create a
2008-07-30 William Jon McCann <jmccann@redhat.com> * common/Makefile.am: * common/gdm-common.c (gdm_make_temp_dir): * common/gdm-common.h: * common/mkdtemp.c: * common/mkdtemp.h: * configure.ac: * daemon/gdm-display-access-file.c (_create_xauth_file_for_user), (gdm_display_access_file_close): Wow, that was really broken. Use mkdtemp when available to create a temporary directory. svn path=/trunk/; revision=6338
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index f698bcef..101b3f4e 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -60,6 +60,12 @@ gdm-marshal.c: gdm-marshal.list
gdm-marshal.h: gdm-marshal.list
@GLIB_GENMARSHAL@ $< --prefix=gdm_marshal --header > $@
+if MKDTEMP_MISSING
+MKDTEMP_FILES = mkdtemp.c mkdtemp.h
+else
+MKDTEMP_FILES =
+endif
+
libgdmcommon_la_SOURCES = \
gdm-address.h \
gdm-address.c \
@@ -90,6 +96,7 @@ libgdmcommon_la_SOURCES = \
gdm-md5.c \
gdm-signal-handler.h \
gdm-signal-handler.c \
+ $(MKDTEMP_FILES) \
$(NULL)
libgdmcommon_la_CPPFLAGS = \
@@ -147,5 +154,7 @@ CLEANFILES = \
EXTRA_DIST = \
gdm-settings.xml \
gdm-marshal.list \
+ mkdtemp.c \
+ mkdtemp.h \
$(gdm_DATA) \
$(NULL)