summaryrefslogtreecommitdiff
path: root/config/Makefile.am
diff options
context:
space:
mode:
authorGeorge Lebl <jirka@5z.com>2002-07-23 18:47:51 +0000
committerGeorge Lebl <jirka@src.gnome.org>2002-07-23 18:47:51 +0000
commit721347aced6de71c99ae58a40e7c0b1e97b850d2 (patch)
treed09c2d49b7c17f86b304903548573312933ba91e /config/Makefile.am
parenta2dfd16fa7c556a89da35645987214980de63fa9 (diff)
downloadgdm-721347aced6de71c99ae58a40e7c0b1e97b850d2.tar.gz
prefer the gnome-session in PATH, fix some startup stuff add
Tue Jul 23 11:20:56 2002 George Lebl <jirka@5z.com> * config/gnomerc.in, config/Makefile.am, config/Xsesssion.in, config/Gnome.in: prefer the gnome-session in PATH, fix some startup stuff add gnome-volume-control init to gnomerc, whack the redhat specific setup, and copy parts of the redhat's Xsession file to our own and if switchdesk is installed make Xsession the default, so now all the good stuff happens on redhat even if you leave the default session. And this Xsession file should work on other systems just as well. * config/gdm.conf.in, config/PreSession, daemon/gdm.h: My gf doesn't like those ugly green backgrounds so change the color to what ximian uses as I kind of like that, (and did I mention that this way it's not green?). Also set the background in PreSession so that you get it for all sessions as default. * daemon/gdm.c: fix error handling of bad reboot/suspend/halt, add chdir ("/") from the hpux ximain patches, in the signal_notify add a main loop wakeup function which may fix some issues possibly the freebsd issues and should make this work on hpux just like the complicated and mostly weird ximian patch.
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index f0f531e8..aa4008be 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -15,14 +15,13 @@ EXTRA_DIST = \
gdm.conf.in \
Gnome.in \
gnomerc.in \
- Xsession \
+ Xsession.in \
gdm \
gdm-autologin \
locale.alias \
Default \
PostSession \
PreSession \
- Default.redhat \
XKeepsCrashing \
gettextfoo.h \
extract-shell.sh
@@ -30,7 +29,7 @@ EXTRA_DIST = \
gettextfoo.h: XKeepsCrashing
cat $^ | $(srcdir)/extract-shell.sh > gettextfoo.h
-install-data-hook: gdm.conf gnomerc Gnome
+install-data-hook: gdm.conf gnomerc Gnome Xsession
if test '!' -d $(DESTDIR)$(confdir); then \
$(mkinstalldirs) $(DESTDIR)$(confdir); \
chmod 755 $(DESTDIR)$(confdir); \
@@ -62,11 +61,11 @@ install-data-hook: gdm.conf gnomerc Gnome
fi
$(INSTALL_SCRIPT) Gnome $(DESTDIR)$(sessdir)/Gnome
- -if test -f /etc/redhat-release; then \
+ -if test -f /usr/bin/switchdesk; then \
if test -f $(DESTDIR)$(sessdir)/Default; then \
cp $(DESTDIR)$(sessdir)/Default $(DESTDIR)$(sessdir)/Default.orig; \
fi; \
- $(INSTALL_SCRIPT) $(srcdir)/Default.redhat $(DESTDIR)$(sessdir)/Default; \
+ $(LN_S) -f $(sessdir)/Xsession $(DESTDIR)$(sessdir)/Default; \
fi
if test '!' -d $(DESTDIR)$(initdir); then \