summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Bechtold <thomasbechtold@jpberlin.de>2013-02-08 16:50:33 +0100
committerThomas Bechtold <thomasbechtold@jpberlin.de>2013-02-08 16:50:33 +0100
commit3b6ab28ec5a754f1042d06a0851916fb8407725a (patch)
tree8e23f7284ab4f6344a6e1d82d6cde27b24521343 /configure.ac
parent9177b8aca0538a4cc6d8cbab8174fb4972512b83 (diff)
downloadgdm-3b6ab28ec5a754f1042d06a0851916fb8407725a.tar.gz
configure: don't enable systemd journal if systemd is disabled
it's possible to fail the have_systemd check because systemd is too old, but still pass the have_journald check because journald is available. This commit ensures that doesn't happen because journald support depends on systemd support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5f5f5be0..00f1ccef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -954,11 +954,16 @@ PKG_CHECK_MODULES(JOURNALD,
[have_journald=yes], [have_journald=no])
if test "x$enable_systemd_journal" = "xauto" ; then
- if test x$have_journald = xno ; then
- use_journald=no
+ if test x$use_systemd = xyes ; then
+ if test x$have_journald = xno ; then
+ use_journald=no
+ else
+ use_journald=yes
+ fi
else
- use_journald=yes
+ use_journald=no
fi
+
else
use_journald="$enable_systemd_journal"
fi