summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2015-06-12 13:28:01 -0400
committerRay Strode <rstrode@redhat.com>2015-06-12 14:29:03 -0400
commit1ac67f522f5690c27023d98096ca817f12f7eb88 (patch)
tree3d562e9ec0ef2ee4822bcd6888c063c5bc92b74f /configure.ac
parent9f96354ba6612f14eade901db0b95cae050d2ab9 (diff)
downloadgdm-1ac67f522f5690c27023d98096ca817f12f7eb88.tar.gz
drop consolekit support
It was deprecated in 3.16 to be removed in 3.18 https://bugzilla.gnome.org/show_bug.cgi?id=743940
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 0 insertions, 38 deletions
diff --git a/configure.ac b/configure.ac
index 01807a8e..80d92aac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -244,10 +244,6 @@ AC_ARG_WITH(tcp-wrappers,
[Use TCP Wrappers @<:@default=auto@:>@]),,
with_tcp_wrappers=auto)
-AC_ARG_WITH(console-kit,
- AS_HELP_STRING([--with-console-kit],
- [Add ConsoleKit support @<:@default=auto@:>@]),,
- with_console_kit=no)
AC_ARG_WITH(systemd,
AS_HELP_STRING([--with-systemd],
@@ -878,18 +874,6 @@ AC_SUBST(XINERAMA_LIBS)
CPPFLAGS="$xinerama_save_cppflags"
dnl ---------------------------------------------------------------------------
-dnl - Check for ConsoleKit support
-dnl ---------------------------------------------------------------------------
-
-use_console_kit=no
-if test "x$with_console_kit" != "xno" ; then
- use_console_kit=yes
- AC_DEFINE(WITH_CONSOLE_KIT, 1, [Define to enable ConsoleKit support])
-fi
-AM_CONDITIONAL(WITH_CONSOLE_KIT, test x$use_console_kit = xyes)
-AC_SUBST(WITH_CONSOLE_KIT)
-
-dnl ---------------------------------------------------------------------------
dnl - Check for systemd support
dnl ---------------------------------------------------------------------------
@@ -1121,14 +1105,6 @@ fi
AC_SUBST(GDM_CUSTOM_CONF)
AC_SUBST(GDM_OLD_CONF, '${gdmconfdir}/gdm.conf')
-AC_ARG_WITH(consolekit-directory,
- [AC_HELP_STRING([--with-consolekit-directory],
- [Specify the directory of ck-get-x11-display-device @<:@default=libexecdir@:>@])],,
- [with_consolekit_directory="\${libexecdir}"])
-
-CONSOLEKIT_DIR=$with_consolekit_directory
-AC_SUBST(CONSOLEKIT_DIR)
-
AC_ARG_WITH(gnome-settings-daemon-directory,
[AC_HELP_STRING([--with-gnome-settings-daemon-directory],
[Specify the directory of gnome-settings-daemon used by the chooser @<:@default=libexecdir@:>@])],,
@@ -1610,7 +1586,6 @@ echo "
dmconfdir: ${dmconfdir}
localstatedir: ${localstatedir}
datadir: ${datadir}
- consolekit location: ${with_consolekit_directory}
gnome-settings-daemon location: ${with_gnome_settings_daemon_directory}
gnome-session-check-accel location: ${with_check_accelerated_directory}
source code location: ${srcdir}
@@ -1640,7 +1615,6 @@ echo \
" Xinerama support: ${XINERAMA_SUPPORT}
XDMCP support: ${XDMCP_SUPPORT}
SELinux support: ${use_selinux}
- ConsoleKit support: ${use_console_kit}
systemd support: ${use_systemd}
systemd unit dir: ${with_systemdsystemunitdir}
plymouth support: ${use_plymouth}
@@ -1650,15 +1624,3 @@ echo \
Enable documentation: ${enable_documentation}
Install GDM's Xsession: ${enable_gdm_xsession}
"
-
-if test x"${use_console_kit}" = x"yes"; then
- echo \
-" WARNING:
- ConsoleKit support is deprecated and is going to be removed before
- the next major release. More details, and patches to add back in
- ConsoleKit support can be found here:
-
- https://wiki.gnome.org/Projects/ConsoleKit
-"
-fi
-