summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-08-06 21:41:16 +0200
committerRay Strode <rstrode@redhat.com>2012-08-06 23:23:38 -0400
commit42ef43e603d65390c2c86e276489c8a08c7808a0 (patch)
treeedd9e5d905138a4741ece8eb1699cf6cdf5fc511 /configure.ac
parentedd5e9cd13df68a16caa69c12b0b18d439022e3b (diff)
downloadgdm-42ef43e603d65390c2c86e276489c8a08c7808a0.tar.gz
gdm: always run gdm on VT1
This drops automatic VT allocation schemes for the initial display in favour of a compile time hardcoded VT assignment. The automatic allocation schemes are inherently racy since a simpler output to the console might already influence it and result in gdm running on another than the intended VT. This patch adds a --with-initial-vt= switch to configure which may be used to set the VT gdm will run the initial server on. It defaults to 1. https://fedoraproject.org/wiki/Features/DisplayManagerRework https://bugzilla.gnome.org/show_bug.cgi?id=511168
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7e962a69..26f7826d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1439,6 +1439,20 @@ else
XSESSION_SHELL=/bin/sh
fi
+#
+# Set VT to use for initial server
+#
+AC_ARG_WITH(initial-vt,
+ AS_HELP_STRING([--with-initial-vt=<nr>],
+ [Initial virtual terminal to use]))
+if ! test -z "$with_initial_vt"; then
+ GDM_INITIAL_VT="$with_initial_vt"
+else
+ GDM_INITIAL_VT="1"
+fi
+AC_SUBST(GDM_INITIAL_VT)
+AC_DEFINE_UNQUOTED(GDM_INITIAL_VT, "$GDM_INITIAL_VT", [Initial Virtual Terminal])
+
# Set configuration choices.
#
AC_SUBST(XSESSION_SHELL)
@@ -1558,4 +1572,5 @@ echo \
plymouth support: ${use_plymouth}
UPower support: ${have_upower}
Build with RBAC: ${msg_rbac_shutdown}
+ Initial VT: ${GDM_INITIAL_VT}
"