summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-12-03 14:05:40 -0500
committerColin Walters <walters@verbum.org>2012-12-03 17:16:40 -0500
commitbeebfcd47cc63eb25b9e4921f78206447b85a517 (patch)
tree9c49a9fc7d99bba10c3dff441cdb44edf77d3ccb /configure.ac
parent924c10cb41a737590046c527bf9d2b382e06c8bf (diff)
downloadgdm-beebfcd47cc63eb25b9e4921f78206447b85a517.tar.gz
build: Don't automatically use _FORTIFY_SOURCE
OS builders can add this flag externally if desired. The problem with us doing this unconditionally, it causes the cpp to spam us with warnings if we're building without optimization (i.e. CFLAGS='-ggdb -O0') which I often do so I can use gdb. https://bugzilla.gnome.org/show_bug.cgi?id=689569
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a778990e..5f579993 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1433,7 +1433,7 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
-Wall \
-Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes \
-Wnested-externs -Wpointer-arith \
- -Wcast-align -Wsign-compare -Wp,-D_FORTIFY_SOURCE=2 \
+ -Wcast-align -Wsign-compare \
$CFLAGS"
for option in -Wno-strict-aliasing -Wno-sign-compare; do