summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2012-10-04 18:13:56 -0400
committerRay Strode <rstrode@redhat.com>2012-10-15 15:04:51 -0400
commit11d4b97bfda92a254d2ef55b4795456367a3cfbb (patch)
tree985119024103d0efb8a21293a245cd8a0c74bfde /configure.ac
parent47c73024739a65614c6a0ddcdd1c08239798044a (diff)
downloadgdm-11d4b97bfda92a254d2ef55b4795456367a3cfbb.tar.gz
daemon: user marker file for tracking autologin instead of static variable.
We currently decide whether or not to skip autologin by a first_login state variable in the static display object. These days we can have multiple static display objects, so storing the state variable doesn't make much sense. We could make the variable static, but instead this commit switches to using a marker file in /var/run/gdm. https://bugzilla.gnome.org/show_bug.cgi?id=682467
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d3635cf4..caa2bc25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1333,6 +1333,26 @@ AC_SUBST(GDM_PID_FILE)
AC_DEFINE_UNQUOTED(GDM_PID_FILE, "$GDM_PID_FILE", [pid file])
dnl ---------------------------------------------------------------------------
+dnl - ran once marker
+dnl ---------------------------------------------------------------------------
+
+AC_ARG_WITH(ran-once-marker-directory,
+ AS_HELP_STRING([--with-ran-once-marker-directory=<dir>],
+ [ran once marker directory]))
+
+if ! test -z "$with_ran_once_marker_directory"; then
+ GDM_RAN_ONCE_MARKER_DIR=$with_ran_once_marker_directory
+else
+ GDM_RAN_ONCE_MARKER_DIR=${localstatedir}/run/gdm
+fi
+AC_SUBST(GDM_RAN_ONCE_MARKER_DIR)
+AC_DEFINE_UNQUOTED(GDM_RAN_ONCE_MARKER_DIR, "$GDM_RAN_ONCE_MARKER_DIR", [ran once marker dir])
+
+GDM_RAN_ONCE_MARKER_FILE="$GDM_RAN_ONCE_MARKER_DIR/ran-once-marker"
+AC_SUBST(GDM_RAN_ONCE_MARKER_FILE)
+AC_DEFINE_UNQUOTED(GDM_RAN_ONCE_MARKER_FILE, "$GDM_RAN_ONCE_MARKER_FILE", [ran once marker file])
+
+dnl ---------------------------------------------------------------------------
dnl - GREETER WORKING DIRECTORY
dnl ---------------------------------------------------------------------------