summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Cameron <brian.cameron@sun.com>2005-12-21 01:38:15 +0000
committerBrian Cameron <bcameron@src.gnome.org>2005-12-21 01:38:15 +0000
commit11c28082c288b2a0aad2ef182ee738965b93ed08 (patch)
tree2d39d8bea2b552fe4db17e1fa66573d333f54d3a /configure.ac
parent2cfd51d25331c7d4cd4413a1d2616c3574ef31c5 (diff)
downloadgdm-11c28082c288b2a0aad2ef182ee738965b93ed08.tar.gz
Patch by Padraig O'Briain <Padraig.OBriain@sun.com>, modified by myself so
2005-12-21 Brian Cameron <brian.cameron@sun.com> Patch by Padraig O'Briain <Padraig.OBriain@sun.com>, modified by myself so it also works with gdmlogin and not just gdmgreeter. Also I integrated his gdmprefetch.c utility into the configure/Makefile system with the --with-prefetch option. * configure.ac: Now support --with-prefetch * daemon/gdm.h, daemon/gdmconfig.c, config/gdm.conf.in: Support new PostDisplayProgram key. * gui/gdmcommon.[ch], gui/gdmlogin.c, gui/greeter/greeter.c: Now support new PostDisplayProgram key. * docs/C/gdm.xml: Add docs for new key. * utils/Makefile.am, utils/gdmprefetch.c: Add new gdmprefetch utility. * config/Makefile.am: Now install gdm.conf file with 444 permissions and always write over the installed gdm.conf after first moving aside the user's gdm.conf file if necessary.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8dfe559d..a2d5d2df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -858,6 +858,15 @@ fi
AC_SUBST(GDM_CONFIGDIR)
AC_DEFINE_UNQUOTED(GDM_CONFIGDIR,"$GDM_CONFIGDIR")
+AC_ARG_WITH(prefetch,
+ [ --with-prefetch=[yes/no] Install GDM library prefetch utility [default=no]],,
+ with_prefetch=no)
+
+if test x$with_prefetch != xno ; then
+ GDMPREFETCH="gdmprefetch"
+fi
+AC_SUBST(GDMPREFETCH)
+
AC_ARG_WITH(xevie,
[ --with-xevie=[yes/no] Add XEvIE Xserver extension support [default=no]],,
with_xevie=no)
@@ -1175,7 +1184,7 @@ dnl <= Authentication scheme =>
echo "Authentication scheme : $VRFY"
dnl <= Utils built =>
-echo "Extra utilities built : "`echo $GDMOPEN $GDMASKPASS`
+echo "Extra utilities built : "`echo $GDMOPEN $GDMASKPASS $GDMPREFETCH`
echo ""
dnl <= End of configuration summary =>