summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2011-05-12 16:36:39 -0400
committerRay Strode <rstrode@redhat.com>2011-06-15 09:58:59 -0400
commit15a3f0c699fe1e8583a33d744edfbb0801ab92bf (patch)
treef4e492219848dd347a0cfb4973b9e5b629e7362e /configure.ac
parent8bf1de19c95b3069e108c9e477785c4e654801f7 (diff)
downloadgdm-15a3f0c699fe1e8583a33d744edfbb0801ab92bf.tar.gz
daemon: clean up greeter when unused
When user switching GDM needs to show a transient greeter for the user to pick a name from the list and jump to that session. After the user has been jumped to the selected session we don't really have a use for the greeter session. Historically, we've kept it around anyway, though, because X by default jumps back to the VT it started on when it exits, and we don't want the user to get thrown to an empty VT after they log out. This commit changes X to get started with the "-novtswitch" option, so that it doesn't do the undesirable switch-on-exit thing. This allows us to clean up the useless greeter following user switches. Based on work by Josselin Mouette <joss@debian.org> https://bugzilla.gnome.org/show_bug.cgi?id=618047
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ecb7e1e5..d54f0f9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -276,6 +276,11 @@ AC_ARG_WITH(at-spi-registryd-directory,
AT_SPI_REGISTRYD_DIR=$with_at_spi_registryd_directory
AC_SUBST(AT_SPI_REGISTRYD_DIR)
+AC_ARG_WITH(vt-switch-workaround,
+ AS_HELP_STRING([--with-vt-switch-workaround],
+ [Try to workaround missing -novtswitch option for X @<:@default=nor@:>@])],,
+ [with_vt_switch_workaround="no"])
+
# Allow configuration of default PATH
#
withval=""
@@ -923,6 +928,14 @@ AM_CONDITIONAL(WITH_CONSOLE_KIT, test x$use_console_kit = xyes)
AC_SUBST(WITH_CONSOLE_KIT)
dnl ---------------------------------------------------------------------------
+dnl - Check for vt switch support
+dnl ---------------------------------------------------------------------------
+
+if test "x$with_vt_switch_workaround" != "xno" ; then
+ AC_DEFINE(WITH_VT_SWITCH_WORKAROUND, 1, [Define to enable workaround for missing -novtswitch feature])
+fi
+
+dnl ---------------------------------------------------------------------------
dnl - Check for D-Bus
dnl ---------------------------------------------------------------------------