summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2016-12-12 10:35:32 -0500
committerRay Strode <rstrode@redhat.com>2016-12-13 14:57:22 -0500
commitca9006193b275dbbecae44e2d8366eed6817fb7e (patch)
tree3454bdbf249f17dca08eae78cae2a0361138915e /configure.ac
parentc27fdd94b068a0c50b648b15e21f6c86a1cdcb24 (diff)
downloadgdm-ca9006193b275dbbecae44e2d8366eed6817fb7e.tar.gz
display: port GdmDisplay to xcb
Xlib will kill the process if it notices the display connection has gone away. This is suboptimal for the main gdm process! This commit ports the Xlib code to xcb, so it won't have the above fragility. https://bugzilla.gnome.org/show_bug.cgi?id=776059
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dd989928..fbf400e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,7 @@ PKG_CHECK_MODULES(DAEMON,
gio-2.0 >= $GLIB_REQUIRED_VERSION
gio-unix-2.0 >= $GLIB_REQUIRED_VERSION
accountsservice >= $ACCOUNTS_SERVICE_REQUIRED_VERSION
+ xcb
)
AC_SUBST(DAEMON_CFLAGS)
AC_SUBST(DAEMON_LIBS)