summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-01-24 00:03:10 +0100
committerLennart Poettering <lennart@poettering.net>2012-02-07 22:57:11 +0100
commit2b24451c3816ecea30fdbfff2c249a6ac527e1b6 (patch)
treeb3a2ef5d97fb154df1c02ae5c022f91cc1b8f4cc /configure.ac
parent51a27a199e36fcb5e90e8332c1f025e8a282fbd5 (diff)
downloadgdm-2b24451c3816ecea30fdbfff2c249a6ac527e1b6.tar.gz
server: invoke X with the systemd multi seat X wrapper if necessary
systemd 39 and newer provide a small wrapper for X which works around the fact that XOrg upstream currently support multi-seat hotplug for displays. Let's make use of this as a stop-gap until this feature is added to XOrg upstream. This code tries to be as defensive as possible and makes use of the wrapper only if the system as actually booted with systemd, the wrapper is available and we actually use a seat != "seat0".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dec31a94..855948d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -939,7 +939,7 @@ use_systemd=no
if test "x$with_systemd" != "xno" ; then
PKG_CHECK_MODULES(SYSTEMD,
libsystemd-daemon
- libsystemd-login
+ libsystemd-login >= 39
)
AC_SUBST(SYSTEMD_CFLAGS)
AC_SUBST(SYSTEMD_LIBS)
@@ -950,6 +950,10 @@ fi
AM_CONDITIONAL(WITH_SYSTEMD, test x$use_systemd = xyes)
AC_SUBST(WITH_SYSTEMD)
+AC_PATH_PROG(SYSTEMD_X_SERVER, systemd-multi-seat-x, [/lib/systemd/systemd-multi-seat-x], [/lib/systemd:/usr/lib/systemd:$PATH])
+AC_SUBST(SYSTEMD_X_SERVER)
+AC_DEFINE_UNQUOTED(SYSTEMD_X_SERVER,"$SYSTEMD_X_SERVER",[Path to systemd X server wrapper])
+
dnl ---------------------------------------------------------------------------
dnl - Check for D-Bus
dnl ---------------------------------------------------------------------------