summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-01-15 16:49:07 -0500
committerColin Walters <walters@verbum.org>2012-04-30 18:34:45 -0400
commit7764799e356fb482f732e3a248e22d69d5e4d86b (patch)
tree4fbc7e69ae7034851233a7d55dd61893f650e4cd /configure.ac
parent67d91afb77a162961c1dd86634a6ebe0136ac7a2 (diff)
downloadgdm-7764799e356fb482f732e3a248e22d69d5e4d86b.tar.gz
build: Add --disable-documentation
Documentation is the source of many cyclical build loops. Allow operating system builders to manually cut these cycles initially by disabling documentation for a first pass. https://bugzilla.gnome.org/show_bug.cgi?id=675087
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c35ad8c1..35e6e047 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,10 @@ AC_CONFIG_MACRO_DIR([m4])
IT_PROG_INTLTOOL([0.40.0])
GNOME_DOC_INIT
+AC_ARG_ENABLE([documentation],
+ AS_HELP_STRING([--enable-documentation], [enable man pages and HTML documentation]),
+ [], [enable_documentation=yes])
+AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)
GETTEXT_PACKAGE=gdm
AC_SUBST(GETTEXT_PACKAGE)