summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <jjardon@gnome.org>2012-08-11 00:00:11 +0900
committerRay Strode <rstrode@redhat.com>2012-09-04 16:48:44 -0400
commitdb048b2f38d19e5b965c8feb931a75a1c3384ff3 (patch)
treea1e2f003e2256dff2c1cb3ddf136b0733aaa14aa /configure.ac
parent0f2caf80bfab50ce4632e9f7944de780a9341cc0 (diff)
downloadgdm-db048b2f38d19e5b965c8feb931a75a1c3384ff3.tar.gz
Use new documentation infrastructure
Use yelp-tools instead gnome-doc-utils https://bugzilla.gnome.org/show_bug.cgi?id=681604
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 40774e50..8458b827 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,10 +41,12 @@ AC_SUBST(VERSION)
AM_CONFIG_HEADER(config.h)
AC_CONFIG_MACRO_DIR([m4])
-GNOME_DOC_INIT
-AC_ARG_ENABLE([documentation],
- AS_HELP_STRING([--enable-documentation], [enable man pages and HTML documentation]),
- [], [enable_documentation=yes])
+# Documentation
+enable_documentation=no
+m4_ifdef([YELP_HELP_INIT],[
+YELP_HELP_INIT
+enable_documentation=yes
+])
AM_CONDITIONAL(ENABLE_DOCUMENTATION, test x$enable_documentation = xyes)
# i18n stuff
@@ -1598,4 +1600,5 @@ echo \
UPower support: ${have_upower}
Build with RBAC: ${msg_rbac_shutdown}
Initial VT: ${GDM_INITIAL_VT}
+ Enable documentation: ${enable_documentation}
"