summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2016-08-15 14:11:01 -0400
committerRay Strode <rstrode@redhat.com>2016-08-19 15:02:07 -0400
commit31ed6f2b3f1ab45ae07aad41c13a51ba91fd159d (patch)
tree7a3ada2efa60d90050f726943bb29160dbce7723 /configure.ac
parent714b6af29b916ac7da0cdab6f83460574ed49cf2 (diff)
downloadgdm-31ed6f2b3f1ab45ae07aad41c13a51ba91fd159d.tar.gz
pam: grab cached password from systemd and pass it on
If the user has an encrypted disk then systemd will cache the password they type into the keyring. It makes sense to try to use this password for automatic login purposes first, since on single user machines, the sole user password is likely to match the disk password. Of course if it doesn't work we'll fall back to the old way of doing automatic login without a password (and then the user will have to manualy enter if they need to for gnome-keyring or whatever) https://bugzilla.gnome.org/show_bug.cgi?id=769950
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cb3a3765..ac6afc55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -522,6 +522,14 @@ if test "x$have_pam" = "xyes"; then
)
fi
+AC_CHECK_LIB(keyutils, keyctl_read, [
+ AC_DEFINE(HAVE_KEYUTILS, 1, [Define if have keyutils])
+ KEYUTILS_LIBS="-lkeyutils"
+ KEYUTILS_CFLAGS=""
+])
+AC_SUBST(KEYUTILS_LIBS)
+AC_SUBST(KEYUTILS_CFLAGS)
+
dnl Check if we can use the setpenv function to add specialvariable
dnl to the environment (such as the /etc/environment file under AIX)
AC_LINK_IFELSE([