summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2012-09-04 16:54:11 -0400
committerRay Strode <rstrode@redhat.com>2012-09-04 16:55:18 -0400
commitb5075ffb9de9177a2026af99446bd7ba1d36c4db (patch)
tree86c5ee38fb11d2e7f8cb79164ccae0ff4c26cae1 /configure.ac
parentdb048b2f38d19e5b965c8feb931a75a1c3384ff3 (diff)
downloadgdm-b5075ffb9de9177a2026af99446bd7ba1d36c4db.tar.gz
data: add rest of LFS pam patch
I misapplied the previous patch and broke the build for everyone but me. This commit fixes that. https://bugzilla.gnome.org/show_bug.cgi?id=683283
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8458b827..cfab145d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,19 +213,20 @@ if test x$enable_split_authentication = xyes; then
fi
AC_ARG_WITH(default-pam-config,
- AS_HELP_STRING([--with-default-pam-config: One of redhat, openembedded, exherbo, none @<:@default=auto@:>@]))
+ AS_HELP_STRING([--with-default-pam-config: One of redhat, openembedded, exherbo, lfs, none @<:@default=auto@:>@]))
dnl If not given, try autodetecting from release files (see NetworkManager source)
if test x$with_default_pam_config = x; then
AC_CHECK_FILE(/etc/redhat-release,with_default_pam_config="redhat")
AC_CHECK_FILE(/etc/fedora-release,with_default_pam_config="redhat")
AC_CHECK_FILE(/etc/exherbo-release,with_default_pam_config="exherbo")
+ AC_CHECK_FILE(/etc/lfs-release,with_default_pam_config="lfs")
dnl If not autodetected, default to none
if test x$with_default_pam_config = x; then
with_default_pam_config=none
fi
fi
case x$with_default_pam_config in
- xredhat|xopenembedded|xexherbo|xnone) ;;
+ xredhat|xopenembedded|xexherbo|xlfs|xnone) ;;
*)
AC_MSG_ERROR([Invalid --with-default-pam-config ${with_default_pam_config}])
exit 1
@@ -234,6 +235,7 @@ esac
AM_CONDITIONAL(ENABLE_REDHAT_PAM_CONFIG, test x$with_default_pam_config = xredhat)
AM_CONDITIONAL(ENABLE_OPENEMBEDDED_PAM_CONFIG, test x$with_default_pam_config = xopenembedded)
AM_CONDITIONAL(ENABLE_EXHERBO_PAM_CONFIG, test x$with_default_pam_config = xexherbo)
+AM_CONDITIONAL(ENABLE_LFS_PAM_CONFIG, test x$with_default_pam_config = xlfs)
AC_ARG_ENABLE(console-helper,
AS_HELP_STRING([--enable-console-helper],