summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFelix Zhang <fezhang@suse.com>2018-01-22 17:08:49 +0800
committerRay Strode <rstrode@redhat.com>2018-02-12 09:51:28 -0500
commit081f29390156858dbd63a108c97d8f95eadbb863 (patch)
tree6566eacc1fc15e4c695a260e3aa2643991d58d06 /configure.ac
parent17a9f3820daccdf5efe41d48d16fd701be12184a (diff)
downloadgdm-081f29390156858dbd63a108c97d8f95eadbb863.tar.gz
common: Support runtime configurations
Add runtime configuration file /run/gdm/custom.conf, making device dependent configurations possible. https://bugzilla.gnome.org/show_bug.cgi?id=789081
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b2ef7f3..c02626bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1424,6 +1424,24 @@ fi
AC_SUBST(GDM_SCREENSHOT_DIR)
dnl ---------------------------------------------------------------------------
+dnl - runtime conf
+dnl ---------------------------------------------------------------------------
+
+withval=""
+AC_ARG_WITH(runtime_conf,
+ AS_HELP_STRING([--with-runtime-conf=<FILENAME>],
+ [FILENAME to give to runtime configuration file @<:@default=GDM_RUN_DIR/custom.conf@:>@]))
+
+if test x$withval != x; then
+ GDM_RUNTIME_CONF="$withval"
+else
+ GDM_RUNTIME_CONF="$GDM_RUN_DIR/custom.conf"
+fi
+
+AC_SUBST(GDM_RUNTIME_CONF)
+
+
+dnl ---------------------------------------------------------------------------
dnl - Finish
dnl ---------------------------------------------------------------------------