summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2017-02-23 13:46:57 -0500
committerRay Strode <rstrode@redhat.com>2017-02-27 17:04:22 -0500
commit22de251816f7c9399f5cddc54ac350e0f445c0dc (patch)
treee328579bf8521f8f9e7bf2bf1be7f75f9533513f /configure.ac
parent5b1e625417c274823c66a552f37d912986fc34d8 (diff)
downloadgdm-22de251816f7c9399f5cddc54ac350e0f445c0dc.tar.gz
daemon: add knob to disable starting X server as user
Some deployments need to be able to turn off running X servers as a user for backward compatibility. This commit adds some #ifdef goop to that end. Note wayland requires running as the user, so this option, merely deprioritizes wayland sessions under X sessions. https://bugzilla.gnome.org/show_bug.cgi?id=779338
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8077038..b609c80a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -195,6 +195,16 @@ if test x$enable_split_authentication = xyes; then
AC_DEFINE(ENABLE_SPLIT_AUTHENTICATION, 1, [Define if split authentication is enabled])
fi
+AC_ARG_ENABLE(user-display-server,
+ AS_HELP_STRING([--enable-user-display-server],
+ [Enable running X server as user @<:@default=yes@:>@]),,
+ enable_user_display_server=yes)
+AM_CONDITIONAL(ENABLE_USER_DISPLAY_SERVER, test x$user_display_server = xyes)
+
+if test x$enable_user_display_server = xyes; then
+ AC_DEFINE(ENABLE_USER_DISPLAY_SERVER, 1, [Define if user display servers are supported])
+fi
+
AC_ARG_WITH(default-pam-config,
AS_HELP_STRING([--with-default-pam-config: One of redhat, openembedded, exherbo, lfs, arch, none @<:@default=auto@:>@]))
dnl If not given, try autodetecting from release files (see NetworkManager source)