summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorJasper St. Pierre <jstpierre@mecheye.net>2012-07-17 17:30:36 -0400
committerJasper St. Pierre <jstpierre@mecheye.net>2012-08-01 12:16:37 -0300
commit2ebfa91823db74a5aea680e6c561a09b709b84ac (patch)
tree41dfd88fbd977716f3dfada3cbe2a243d64285fa /daemon/Makefile.am
parent67235fd797e5b9a88178f4733551814b61a4711b (diff)
downloadgdm-2ebfa91823db74a5aea680e6c561a09b709b84ac.tar.gz
daemon: Rename GdmWelcomeSession to GdmLaunchEnvironment
"GdmWelcomeSession" was always a sort of bad name, as it is not a GdmSession, itself (it has-a GdmSession), and it's unnecessarily generic; it doesn't really have anything to do with "Welcome" or "Session" itself. It managed a non-user GdmSession, spawned the process in the correct environment (spawning a DBus daemon if need be) and made sure to keep track of it until it died. I think "GdmLaunchEnvironment" is an appropriate name for this. https://bugzilla.gnome.org/show_bug.cgi?id=678057
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index b7c86c4e..1e497e55 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -150,8 +150,8 @@ endif
gdm_simple_slave_SOURCES = \
simple-slave-main.c \
- gdm-welcome-session.c \
- gdm-welcome-session.h \
+ gdm-launch-environment.c \
+ gdm-launch-environment.h \
gdm-server.c \
gdm-server.h \
gdm-session.c \
@@ -208,8 +208,8 @@ gdm_xdmcp_chooser_slave_SOURCES = \
gdm-session-worker-common.h \
gdm-session-worker-job.c \
gdm-session-worker-job.h \
- gdm-welcome-session.c \
- gdm-welcome-session.h \
+ gdm-launch-environment.c \
+ gdm-launch-environment.h \
gdm-xerrors.h \
gdm-xerrors.c \
gdm-slave.c \