summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorGiovanni Campagna <gcampagna@src.gnome.org>2012-05-07 18:58:11 +0200
committerRay Strode <rstrode@redhat.com>2012-07-17 04:14:55 -0400
commit53e24b49b05adaf21b1835a8052e2c34aa2c8c7e (patch)
treed67863b600fa3fa50129fa0a40613d06064b6c53 /daemon/Makefile.am
parent3eeec6eec9bcc52da9a788a6ab21b162c275c2b5 (diff)
downloadgdm-53e24b49b05adaf21b1835a8052e2c34aa2c8c7e.tar.gz
daemon: Port GdmSession to use GDBus
GdmSession is an object in the slave that manages the various session worker processes. Each session worker process talks to PAM to perform authentication for the user. For instance, if the user has a fingerprint reader, then there will normally be two worker processes, one for handling fingerprint auth, and one for handling password auth. GdmSession is the interface layer in the slave to talking to those running worker processes. This commit ports GdmSession over to GDBus from dbus-glib. https://bugzilla.gnome.org/show_bug.cgi?id=622888
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index b8d43f5e..d8e151b8 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -37,6 +37,7 @@ BUILT_SOURCES = \
gdm-transient-display-glue.h \
gdm-local-display-factory-glue.h \
gdm-greeter-glue.h \
+ gdm-session-glue.h \
$(NULL)
gdm-display-glue.c gdm-display-glue.h: gdm-display.xml Makefile.am
@@ -74,6 +75,13 @@ gdm-local-display-factory-glue.c gdm-local-display-factory-glue.h : gdm-local-di
--generate-c-code=gdm-local-display-factory-glue \
$(srcdir)/gdm-local-display-factory.xml
+gdm-session-glue.c gdm-session-glue.h : gdm-session.xml Makefile.am
+ $(AM_V_GEN)gdbus-codegen \
+ --c-namespace=GdmDBus \
+ --interface-prefix=org.gnome.DisplayManager \
+ --generate-c-code=gdm-session-glue \
+ $(srcdir)/gdm-session.xml
+
gdm-greeter-glue.c gdm-greeter-glue.h : gdm-greeter-server.xml Makefile.am
$(AM_V_GEN)gdbus-codegen \
--c-namespace=GdmDBus \
@@ -106,6 +114,13 @@ test_session_SOURCES = \
gdm-session-record.c \
gdm-session-record.h \
gdm-session-worker-job.c\
+ gdm-dbus-util.c \
+ gdm-dbus-util.h \
+ $(NULL)
+
+nodist_test_session_SOURCES = \
+ gdm-session-glue.c \
+ gdm-session-glue.h \
$(NULL)
test_session_LDADD = \
@@ -159,6 +174,8 @@ nodist_gdm_simple_slave_SOURCES = \
gdm-greeter-glue.h \
gdm-display-glue.c \
gdm-display-glue.h \
+ gdm-session-glue.c \
+ gdm-session-glue.h \
gdm-slave-glue.c \
gdm-slave-glue.h \
$(NULL)
@@ -351,6 +368,7 @@ CLEANFILES = \
gdm-display-glue.c \
gdm-greeter-glue.c \
gdm-local-display-factory-glue.c \
+ gdm-session-glue.c \
gdm-slave-glue.c \
gdm-static-display-glue.c \
gdm-transient-display-glue.c \