summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
authorWilliam Jon McCann <mccann@jhu.edu>2007-10-04 15:14:48 +0000
committerWilliam Jon McCann <mccann@src.gnome.org>2007-10-04 15:14:48 +0000
commitdae89542cc21cd03bb0debe651b3e30b84289478 (patch)
tree693c854e5ae8a8f84921a373ba7682323f4f2bcc /daemon/Makefile.am
parentf0de3c35d5b967f4117497ba3f5b9d9362b31dd1 (diff)
downloadgdm-dae89542cc21cd03bb0debe651b3e30b84289478.tar.gz
Fix up the handling of dependencies. Make the daemon only depend on x11,
2007-10-04 William Jon McCann <mccann@jhu.edu> * acinclude.m4: * common/Makefile.am: * configure.ac: * daemon/Makefile.am: * daemon/gdm-factory-slave.c: (run_greeter), (idle_connect_to_display): * daemon/gdm-product-slave.c: (setup_server), (idle_connect_to_display): * daemon/gdm-simple-slave.c: (run_greeter), (idle_connect_to_display): * daemon/gdm-slave.c: (gdm_slave_set_busy_cursor), (set_local_auth), (gdm_slave_connect_to_x11_display): * daemon/gdm-slave.h: * gui/Makefile.am: * gui/modules/.cvsignore: * gui/modules/AccessDwellMouseEvents.in: * gui/modules/AccessKeyMouseEvents.in: * gui/modules/Makefile.am: * gui/modules/dwellmouselistener.c: * gui/modules/keymouselistener.c: * gui/simple-chooser/Makefile.am: * gui/simple-greeter/Makefile.am: * gui/simple-greeter/libnotificationarea/Makefile.am: * libgreeter/Makefile.am: Fix up the handling of dependencies. Make the daemon only depend on x11, glib, gobject, dbus. Move some things from the slaves to the base class. Remove the unused modules for now. svn path=/branches/mccann-gobject/; revision=5338
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am60
1 files changed, 5 insertions, 55 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index afaaf7ad..fdf9b967 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -1,7 +1,5 @@
NULL =
-# Note that we have cflags for just about everything even if
-# we don't link to everything
INCLUDES = \
-I. \
-I.. \
@@ -21,12 +19,11 @@ INCLUDES = \
-DGDM_DEFAULTS_CONF=\"$(GDM_DEFAULTS_CONF)\" \
-DGDM_CUSTOM_CONF=\"$(GDM_CUSTOM_CONF)\" \
-DGDM_OLD_CONF=\"$(GDM_OLD_CONF)\" \
- $(GUI_CFLAGS) \
+ $(DISABLE_DEPRECATED_CFLAGS) \
$(DAEMON_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DEBUG_CFLAGS) \
-DLANG_CONFIG_FILE=\"$(LANG_CONFIG_FILE)\" \
- $(GNOME_INCLUDEDIR) \
- -DGREETERTHEMEDIR=\""$(datadir)/gdm/themes"\" \
- $(DBUS_CFLAGS) \
$(NULL)
BUILT_SOURCES = \
@@ -74,10 +71,8 @@ test_session_SOURCES = \
$(NULL)
test_session_LDADD = \
- $(GLIB_LIBS) \
- $(GOBJECT_LIBS) \
+ $(DAEMON_LIBS) \
$(PAM_LIBS) \
- $(DBUS_LIBS) \
$(NULL)
libexec_PROGRAMS = \
@@ -113,23 +108,12 @@ gdm_simple_slave_SOURCES = \
$(NULL)
gdm_simple_slave_LDFLAGS = \
- $(EXTRA_SLAVE_LIBS) \
$(PAM_LIBS) \
$(NULL)
gdm_simple_slave_LDADD = \
$(DAEMON_LIBS) \
- $(INTLLIBS) \
- $(GLIB_LIBS) \
- $(GOBJECT_LIBS) \
- $(GDK_LIBS) \
$(top_builddir)/common/libgdmcommon.la \
- $(X_LIBS) \
- $(XINERAMA_LIBS) \
- $(DBUS_LIBS) \
- -lXau \
- -lX11 \
- -lXext \
$(NULL)
gdm_factory_slave_SOURCES = \
@@ -159,17 +143,7 @@ gdm_factory_slave_LDFLAGS = \
gdm_factory_slave_LDADD = \
$(DAEMON_LIBS) \
- $(INTLLIBS) \
- $(GLIB_LIBS) \
- $(GOBJECT_LIBS) \
- $(GDK_LIBS) \
$(top_builddir)/common/libgdmcommon.la \
- $(X_LIBS) \
- $(XINERAMA_LIBS) \
- $(DBUS_LIBS) \
- -lXau \
- -lX11 \
- -lXext \
$(NULL)
gdm_product_slave_SOURCES = \
@@ -192,23 +166,12 @@ gdm_product_slave_SOURCES = \
$(NULL)
gdm_product_slave_LDFLAGS = \
- $(EXTRA_SLAVE_LIBS) \
$(PAM_LIBS) \
$(NULL)
gdm_product_slave_LDADD = \
$(DAEMON_LIBS) \
- $(INTLLIBS) \
- $(GLIB_LIBS) \
- $(GOBJECT_LIBS) \
- $(GDK_LIBS) \
$(top_builddir)/common/libgdmcommon.la \
- $(X_LIBS) \
- $(XINERAMA_LIBS) \
- $(DBUS_LIBS) \
- -lXau \
- -lX11 \
- -lXext \
$(NULL)
gdm_session_worker_SOURCES = \
@@ -222,10 +185,8 @@ gdm_session_worker_LDFLAGS = \
$(NULL)
gdm_session_worker_LDADD = \
- $(GLIB_LIBS) \
- $(GOBJECT_LIBS) \
+ $(DAEMON_LIBS) \
$(top_builddir)/common/libgdmcommon.la \
- $(DBUS_LIBS) \
$(NULL)
sbin_PROGRAMS = \
@@ -289,18 +250,7 @@ gdm_binary_LDFLAGS = \
gdm_binary_LDADD = \
$(DAEMON_LIBS) \
- $(INTLLIBS) \
- $(GLIB_LIBS) \
- $(GOBJECT_LIBS) \
- $(GDK_LIBS) \
$(top_builddir)/common/libgdmcommon.la \
- $(X_LIBS) \
- $(XINERAMA_LIBS) \
- $(XDMCP_LIBS) \
- $(DBUS_LIBS) \
- -lXau \
- -lX11 \
- -lXext \
$(NULL)
if WITH_CONSOLE_KIT