summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-04-27 18:34:39 -0400
committerColin Walters <walters@verbum.org>2012-07-10 10:26:53 -0400
commit295d0bc42b11a9473a024b9cdca58bdd9197e905 (patch)
tree9a1293d2b9cb90fcc07b566e263e5a4c81ae6aea /data/Makefile.am
parentf42e685e271015d5cc5d52342a8832010f65c5d2 (diff)
downloadgdm-295d0bc42b11a9473a024b9cdca58bdd9197e905.tar.gz
Add --with-default-pam-config option, autodetect from /etc/foo-release files
The PAM files that ship with GDM are really specific to Red Hat's historical fork of pam. For example, the "system-auth" file still lives in the Fedora 17 "pam" git. A long while back, Debian hit the same problem, and of course the difference is the naming; common-auth/common-password etc. OpenEmbedded then picked up Debian's PAM fork. Since for OSTree-GNOME we're using Poky/OpenEmbedded, let's add an option to integrate with their PAM. We use code similar to what NetworkManager has, so we should keep using the Red Hat files on systems with /etc/redhat-release or /etc/fedora-release. https://bugzilla.gnome.org/show_bug.cgi?id=675085
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index dc0301b8..19823491 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -98,6 +98,19 @@ pam_redhat_files = pam-redhat/gdm.pam \
$(NULL)
EXTRA_DIST += $(pam_redhat_files)
+pam_openembedded_files = pam-openembedded/gdm.pam \
+ pam-openembedded/gdm-autologin.pam \
+ pam-openembedded/gdm-welcome.pam \
+ $(NULL)
+EXTRA_DIST += $(pam_openembedded_files)
+
+if ENABLE_REDHAT_PAM_CONFIG
+pam_files = $(pam_redhat_files)
+endif
+if ENABLE_OPENEMBEDDED_PAM_CONFIG
+pam_files = $(pam_openembedded_files)
+endif
+
EXTRA_DIST += \
$(schemas_in_files) \
$(schemas_DATA) \
@@ -223,7 +236,7 @@ install-data-hook: gdm.conf-custom Xsession Init PostSession PreSession 00-upstr
chmod 755 $(DESTDIR)$(PAM_PREFIX)/pam.d; \
fi; \
if test $$system = Linux; then \
- for pamfile in $(pam_redhat_files); do \
+ for pamfile in $(pam_files); do \
bn=$$(basename $$pamfile .pam); \
$(INSTALL_DATA) $(srcdir)/$$pamfile $(DESTDIR)$(PAM_PREFIX)/pam.d/$$bn; \
done; \