summaryrefslogtreecommitdiff
path: root/gui/Makefile.am
diff options
context:
space:
mode:
authorGeorge Lebl <jirka@5z.com>2003-10-16 16:58:22 +0000
committerGeorge Lebl <jirka@src.gnome.org>2003-10-16 16:58:22 +0000
commit4e0346e38c177a2c35b0aa644cc7529fcd30227f (patch)
tree6bf2f65f262e31f0c3e637da247fabd0dfd88c6f /gui/Makefile.am
parent955b1cdc05e300b0ad264b5b9e80bfb6f9a3455a (diff)
downloadgdm-4e0346e38c177a2c35b0aa644cc7529fcd30227f.tar.gz
Make the socket connection non-blocking and limit conversations to 20
Thu Oct 16 09:13:48 2003 George Lebl <jirka@5z.com> * daemon/gdm.[ch], daemon/gdm-net.[ch]: Make the socket connection non-blocking and limit conversations to 20 requests. Also cut lines short at 4096. Fixes CAN-2003-0793 and CAN-2003-0794 respectively. * daemon/slave.c: fix #123958 by clearing the message after authentication is done for the configurator. * daemon/Makefile.am, gui/greeter/Makefile.am, gui/Makefile.am, gui/modules/Makefile.am: The disable_deprecated defines should only be on for conformance testing I suppose. Fixes #124680
Diffstat (limited to 'gui/Makefile.am')
-rw-r--r--gui/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/gui/Makefile.am b/gui/Makefile.am
index 66618c51..aa050e03 100644
--- a/gui/Makefile.am
+++ b/gui/Makefile.am
@@ -13,16 +13,19 @@ DEFS = @DEFS@ \
INCLUDES = \
-I. \
-I.. \
- -DG_DISABLE_DEPRECATED \
- -DGDK_DISABLE_DEPRECATED \
- -DGDK_PIXBUF_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED \
- -DGNOME_DISABLE_DEPRECATED \
-I$(top_srcdir)/daemon \
-I$(top_srcdir)/vicious-extensions \
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
$(GUI_CFLAGS)
+#
+# -DG_DISABLE_DEPRECATED \
+# -DGDK_DISABLE_DEPRECATED \
+# -DGDK_PIXBUF_DISABLE_DEPRECATED \
+# -DGTK_DISABLE_DEPRECATED \
+# -DGNOME_DISABLE_DEPRECATED \
+#
+
noinst_LIBRARIES = libgdmwm.a libgdmlang.a
bin_PROGRAMS = \