summaryrefslogtreecommitdiff
path: root/gui/Makefile.am
diff options
context:
space:
mode:
authorBrian Cameron <Brian.Cameron@sun.com>2005-07-20 17:24:46 +0000
committerBrian Cameron <bcameron@src.gnome.org>2005-07-20 17:24:46 +0000
commit1845776026399dca17be4767f082e53f3df85f0a (patch)
treee0cb90caabaa68a0a435d8de2bb58c11cab00e27 /gui/Makefile.am
parent853d2d7d18fc07578c3a753a5a7854ee51271e6e (diff)
downloadgdm-1845776026399dca17be4767f082e53f3df85f0a.tar.gz
Moved gdm_common_show_info_msg, gdm_common_msg and gdm_common_query from
2005-07-20 Brian Cameron <Brian.Cameron@sun.com> * gui/Makefile.am, gui/gdmcommon.c, gdmwm.c: Moved gdm_common_show_info_msg, gdm_common_msg and gdm_common_query from gdmcommon.c to gdmwm.c. Now no longer include gdmwm.[ch] in libgdmcommon.a since these are in libgdmwm.a: This is cleaner since these 3 functions reference gdmwm functions. This fixes a link problem on Solaris caused because the Xinerama functions were getting referenced in gdmsetup even though they are unused. * gui/gdmphotosetup.c: Now use chmod instead of g_chmod.
Diffstat (limited to 'gui/Makefile.am')
-rw-r--r--gui/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gui/Makefile.am b/gui/Makefile.am
index f2be3da7..a54ac07b 100644
--- a/gui/Makefile.am
+++ b/gui/Makefile.am
@@ -65,8 +65,6 @@ libgdmwm_a_SOURCES = \
gdmwm.h
libgdmcommon_a_SOURCES = \
- gdmwm.c \
- gdmwm.h \
gdmlanguages.c \
gdmlanguages.h \
gdmuser.c \
@@ -94,6 +92,7 @@ gdmsetup_SOURCES = \
gdmchooser_LDFLAGS = -export-dynamic
gdmchooser_LDADD = \
$(EXTRA_CHOOSER_LIBS) \
+ libgdmwm.a \
libgdmcommon.a \
$(GUIGLADE_LIBS) \
$(X_LIBS) \
@@ -112,6 +111,7 @@ gdmchooser_LDADD = \
-lviciousui
gdmlogin_LDADD = \
+ libgdmwm.a \
libgdmcommon.a \
$(GUING_LIBS) \
$(X_LIBS) \