summaryrefslogtreecommitdiff
path: root/pam_gdm/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2018-07-22 10:36:48 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2018-07-22 15:10:57 +0200
commit6e91a9b03c5d76cdd72af4446b07d8da67a44585 (patch)
treecefc1403f16a249cf8e93dbf6a40b9f8e08f80e4 /pam_gdm/meson.build
parentee10daa6495e7e2b8f2ce3475bba4968e1f767ce (diff)
downloadgdm-6e91a9b03c5d76cdd72af4446b07d8da67a44585.tar.gz
Allow building GDM with Meson.wip/nielsdg/meson
WIP WIP WIP WIP Solves #350.
Diffstat (limited to 'pam_gdm/meson.build')
-rw-r--r--pam_gdm/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/pam_gdm/meson.build b/pam_gdm/meson.build
new file mode 100644
index 00000000..f47d8e6a
--- /dev/null
+++ b/pam_gdm/meson.build
@@ -0,0 +1,16 @@
+pam_gdm_deps = [
+ libpam_dep,
+]
+
+if keyutils_dep.found()
+ pam_gdm_deps += keyutils_dep
+endif
+
+pam_gdm = library('pam_gdm',
+ 'pam_gdm.c',
+ dependencies: pam_gdm_deps,
+ include_directories: config_h_dir,
+ name_prefix: '',
+ install: true,
+ install_dir: pam_mod_dir,
+)