summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <nielsdegraef@gmail.com>2018-07-22 10:36:48 +0200
committerNiels De Graef <nielsdegraef@gmail.com>2018-07-22 15:10:57 +0200
commit6e91a9b03c5d76cdd72af4446b07d8da67a44585 (patch)
treecefc1403f16a249cf8e93dbf6a40b9f8e08f80e4 /tests/meson.build
parentee10daa6495e7e2b8f2ce3475bba4968e1f767ce (diff)
downloadgdm-6e91a9b03c5d76cdd72af4446b07d8da67a44585.tar.gz
Allow building GDM with Meson.wip/nielsdg/meson
WIP WIP WIP WIP Solves #350.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 00000000..128b5d2e
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,17 @@
+m_common_test_src = [
+ 'm-common.c',
+ 's-common-address.c',
+ 's-common.c',
+]
+
+m_common_test_deps = [
+ libgdmcommon_dep,
+ libcheck_dep,
+]
+
+m_common_test = executable('m-common',
+ m_common_test_src,
+ dependencies: m_common_test_deps,
+)
+
+test('m-common', m_common_test)