summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorMark McLoughlin <mark@skynet.ie>2005-04-22 16:29:20 +0000
committerMark McLoughlin <markmc@src.gnome.org>2005-04-22 16:29:20 +0000
commitcbacaed0e62147451be3883e64ec55898caf8d15 (patch)
tree9a1177f5dccf2cd8d5ed9c1c46972cc1ecd47727 /utils/Makefile.am
parentedfe5f290bb21db973205b7186f802df8b6ffa74 (diff)
downloadgdm-cbacaed0e62147451be3883e64ec55898caf8d15.tar.gz
Add the ability to make GDM spawn XDMCP sessions on a local X proxy
2005-04-22 Mark McLoughlin <mark@skynet.ie> Add the ability to make GDM spawn XDMCP sessions on a local X proxy server. Experimental support for disconnect/reconnect or "session migration" is also implemented using DMX. More details in bug #301602. * configure.in: require glib 2.6.0 and check for DMX. * config/gdm.conf.in: add xdmpc/EnableProxy, xdmcp/ProxyXServer and xdmcp/ProxyReconnect config keys. * docs/C/gdm.xml: document new config keys. * daemon/gdm.h: add TYPE_XDMCP_PROXY server type, add #defines for the new config keys, re-name various xnest related GdmDisplay members to be applicable for all proxy servers, add xdmcp_dispnum GdmDisplay member, modify the format of GDM_SOP_QUERYLOGIN and add GDM_SOP_AUTHFILE and GDM_SOP_MIGRATE. * daemon/gdm.c: read the new config keys, change format of what GDM_SOP_QUERYLOGIN returns, implement GDM_SOP_AUTHFILE and GDM_SOP_MIGRATE. * daemon/xdmcp.h: add gdm_xdmcp_migrate. * daemon/xdmcp.c: when xdmpc/EnableProxy and xdmcp/ProxyXServer, set things up such that a proxy sever (which displays on the requesting X server) is run locally by the slave. Also implement migrating the proxy server from one parent display to another using the xdmcp/ProxyReconnect command. * daemon/server.c: if we're running a proxy server (e.g. Xnest or Xdmx), hold a connection open to the parent display so that it doesn't reset. Run proxy servers with -display rather than setting $DISPLAY. * daemon/slave.c: Once we've successfully logged the user in, send SOP_QUERYLOGIN to the slave - if the result from that indicates that the user is already logged in and that session is migratable (e.g. by reconnecting a proxy server or changing the VT), then migrate to the existing session using SOP_MIGRATE. In the case of an Xdmcp proxy, hold open the connection to the parent display so that it doesn't reset. Exit the slave as soon as that connection closes. * utils/Makefile.am, utils/gdm-dmx-reconnect-proxy.c: implementation of xdmcp/ProxyReconnect for use with Xdmx.
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index f22e4363..7ec28603 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -20,6 +20,10 @@ libexec_PROGRAMS = \
# bin_PROGRAMS = \
# gdmmktemp
+if DMX_SUPPORT
+bin_PROGRAMS = gdm-dmx-reconnect-proxy
+endif
+
EXTRA_PROGRAMS = gdmaskpass gdmopen
gdmaskpass_SOURCES = \
@@ -47,3 +51,15 @@ gdmtranslate_LDADD = \
#gdmmktemp_LDADD = \
# $(INTLLIBS)
+
+if DMX_SUPPORT
+gdm_dmx_reconnect_proxy_SOURCES = \
+ gdm-dmx-reconnect-proxy.c
+
+gdm_dmx_reconnect_proxy_LDADD = \
+ $(GLIB_LIBS) \
+ $(X_EXTRA_LIBS) \
+ $(X_LIBS) \
+ -lX11 \
+ $(DMX_LIBS)
+endif