summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bedac99a..7b6346cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1232,6 +1232,14 @@ else
fi
dnl ---------------------------------------------------------------------------
+dnl - Check if Xorg is new enough to require '-listen tcp' (1.17)
+dnl ---------------------------------------------------------------------------
+
+if $PKG_CONFIG --atleast-version=1.17 xorg-server; then
+ AC_DEFINE([HAVE_XSERVER_THAT_DEFAULTS_TO_LOCAL_ONLY], [], [XServer disables tcp access by default])
+fi
+
+dnl ---------------------------------------------------------------------------
dnl - Check for Xnest / Xephyr support
dnl ---------------------------------------------------------------------------