summaryrefslogtreecommitdiff
path: root/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/Makefile.am')
-rw-r--r--daemon/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/daemon/Makefile.am b/daemon/Makefile.am
index 1f2feb49..bbd0252d 100644
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -112,6 +112,7 @@ test_session_client_LDADD = \
libexec_PROGRAMS = \
gdm-session-worker \
gdm-wayland-session \
+ gdm-x-session \
$(NULL)
gdm_session_worker_SOURCES = \
@@ -155,6 +156,20 @@ gdm_wayland_session_SOURCES = \
gdm-wayland-session.c \
$(NULL)
+gdm_x_session_LDADD = \
+ $(top_builddir)/common/libgdmcommon.la \
+ $(GTK_LIBS) \
+ $(COMMON_LIBS) \
+ $(SYSTEMD_LIBS) \
+ $(XLIB_LIBS) \
+ $(NULL)
+
+gdm_x_session_SOURCES = \
+ gdm-manager-glue.h \
+ gdm-manager-glue.c \
+ gdm-x-session.c \
+ $(NULL)
+
if HAVE_LIBAUDIT
gdm_session_worker_SOURCES += gdm-session-linux-auditor.h \
gdm-session-linux-auditor.c