summaryrefslogtreecommitdiff
path: root/daemon/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'daemon/meson.build')
-rw-r--r--daemon/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/daemon/meson.build b/daemon/meson.build
index 72c7c3c1..2e61b644 100644
--- a/daemon/meson.build
+++ b/daemon/meson.build
@@ -1,4 +1,10 @@
# D-Bus interfaces
+dbus_gen = gnome.gdbus_codegen('gdm-dbus-glue',
+ 'org.freedesktop.DBus.xml',
+ namespace: 'GdmDBus',
+ interface_prefix: 'org.freedesktop.DBus',
+ autocleanup: 'all',
+)
display_dbus_gen = gnome.gdbus_codegen('gdm-display-glue',
'gdm-display.xml',
namespace: 'GdmDBus',
@@ -87,6 +93,7 @@ gdm_session_worker_src = [
'gdm-session-worker-job.c',
'gdm-session-worker-common.c',
'gdm-dbus-util.c',
+ dbus_gen,
session_dbus_gen,
session_worker_dbus_gen,
gdm_session_enums,