summaryrefslogtreecommitdiff
path: root/gui/simple-greeter/extensions/smartcard/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gui/simple-greeter/extensions/smartcard/Makefile.am')
-rw-r--r--gui/simple-greeter/extensions/smartcard/Makefile.am79
1 files changed, 79 insertions, 0 deletions
diff --git a/gui/simple-greeter/extensions/smartcard/Makefile.am b/gui/simple-greeter/extensions/smartcard/Makefile.am
new file mode 100644
index 00000000..986bf56c
--- /dev/null
+++ b/gui/simple-greeter/extensions/smartcard/Makefile.am
@@ -0,0 +1,79 @@
+SUBDIRS = icons
+
+NULL =
+PAM_SERVICE_NAME = gdm-smartcard
+
+gsettings_SCHEMAS =org.gnome.display-manager.extensions.smartcard.gschema.xml
+@INTLTOOL_XML_NOMERGE_RULE@
+@GSETTINGS_RULES@
+
+extensiondir = $(GDM_SIMPLE_GREETER_EXTENSIONS_DATA_DIR)/smartcard
+extension_DATA = page.ui
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/common \
+ -I$(top_srcdir)/gui/simple-greeter/libgdmsimplegreeter \
+ -DDMCONFDIR=\""$(dmconfdir)"\" \
+ -DGDMCONFDIR=\"$(gdmconfdir)\" \
+ -DPLUGINDATADIR=\""$(extensiondir)"\" \
+ -DGDM_SMARTCARD_EXTENSION_SERVICE_NAME=\""$(PAM_SERVICE_NAME)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DLIBLOCALEDIR=\""$(prefix)/lib/locale"\" \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DLIBEXECDIR=\""$(libexecdir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DSBINDIR=\""$(sbindir)"\" \
+ $(DISABLE_DEPRECATED_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(SIMPLE_GREETER_CFLAGS) \
+ $(POLKIT_GNOME_CFLAGS) \
+ $(NULL)
+
+plugindir = $(GDM_SIMPLE_GREETER_PLUGINS_DIR)
+plugin_LTLIBRARIES = libsmartcard.la
+
+libsmartcard_la_CFLAGS = \
+ $(SIMPLE_GREETER_CFLAGS) \
+ $(NULL)
+
+libexec_PROGRAMS = \
+ gdm-smartcard-worker \
+ $(NULL)
+
+libsmartcard_la_LDFLAGS = -module -avoid-version -export-dynamic
+libsmartcard_la_LIBADD = ../../../../common/libgdmcommon.la \
+ ../../libgdmsimplegreeter/libgdmsimplegreeter.la
+libsmartcard_la_SOURCES = \
+ gdm-smartcard-extension.h \
+ gdm-smartcard-extension.c
+
+gdm_smartcard_worker_LDADD = ../../../../common/libgdmcommon.la \
+ $(DAEMON_LIBS) \
+ $(GTHREAD_LIBS) \
+ $(NSS_LIBS) \
+ $(NULL)
+gdm_smartcard_worker_CFLAGS = $(DAEMON_CFLAGS) \
+ $(NSS_CFLAGS) \
+ $(NULL)
+gdm_smartcard_worker_SOURCES = \
+ gdm-smartcard.h \
+ gdm-smartcard.c \
+ gdm-smartcard-manager.h \
+ gdm-smartcard-manager.c \
+ gdm-smartcard-worker.c \
+ $(NULL)
+
+$(PAM_SERVICE_NAME): $(PAM_SERVICE_NAME).pam
+ cp $(PAM_SERVICE_NAME).pam $(PAM_SERVICE_NAME)
+
+pamdir = $(PAM_PREFIX)/pam.d
+pam_DATA = $(PAM_SERVICE_NAME)
+
+EXTRA_DIST = $(extension_DATA) $(gsettings_SCHEMAS) $(PAM_SERVICE_NAME).pam
+CLEANFILES = $(PAM_SERVICE_NAME) $(gsettings_SCHEMAS)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ $(PAM_SERVICE_NAME) \
+ $(gsettings_SCHEMAS) \
+ Makefile.in