summaryrefslogtreecommitdiff
path: root/gui/simple-greeter/libnotificationarea/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gui/simple-greeter/libnotificationarea/Makefile.am')
-rw-r--r--gui/simple-greeter/libnotificationarea/Makefile.am66
1 files changed, 0 insertions, 66 deletions
diff --git a/gui/simple-greeter/libnotificationarea/Makefile.am b/gui/simple-greeter/libnotificationarea/Makefile.am
deleted file mode 100644
index d1c82e34..00000000
--- a/gui/simple-greeter/libnotificationarea/Makefile.am
+++ /dev/null
@@ -1,66 +0,0 @@
-NULL =
-
-INCLUDES = \
- -I. \
- -I.. \
- -DBINDIR=\"$(bindir)\" \
- -DDATADIR=\"$(datadir)\" \
- -DLIBDIR=\"$(libdir)\" \
- -DLIBEXECDIR=\"$(libexecdir)\" \
- -DLOGDIR=\"$(logdir)\" \
- -DPIXMAPDIR=\"$(pixmapdir)\" \
- -DSBINDIR=\"$(sbindir)\" \
- $(GREETER_CFLAGS) \
- $(NULL)
-
-noinst_LTLIBRARIES = \
- libnotificationarea.la \
- $(NULL)
-
-BUILT_SOURCES = \
- na-marshal.c \
- na-marshal.h \
- $(NULL)
-
-libnotificationarea_la_SOURCES = \
- fixedtip.h \
- fixedtip.c \
- obox.c \
- obox.h \
- na-tray.c \
- na-tray.h \
- na-tray-manager.c \
- na-tray-manager.h \
- na-marshal.c \
- na-marshal.h \
- $(NULL)
-
-libnotificationarea_la_LIBADD = \
- $(GUI_LIBS) \
- $(NULL)
-
-libnotificationarea_la_LDFLAGS = \
- -export-dynamic \
- $(NULL)
-
-EXTRA_DIST = \
- na-marshal.list \
- $(NULL)
-
-na-marshal.h: na-marshal.list $(GLIB_GENMARSHAL)
- $(GLIB_GENMARSHAL) $< --header --prefix=_na_marshal > $@
-
-na-marshal.c: na-marshal.list $(GLIB_GENMARSHAL)
- echo "#include \"na-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) $< --body --prefix=_na_marshal >> $@
-
-noinst_PROGRAMS = testtray
-
-testtray_SOURCES = \
- testtray.c \
- $(NULL)
-
-testtray_LDADD = \
- libnotificationarea.la \
- $(GREETER_LIBS) \
- $(NULL)