summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index f22e4363..7ec28603 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -20,6 +20,10 @@ libexec_PROGRAMS = \
# bin_PROGRAMS = \
# gdmmktemp
+if DMX_SUPPORT
+bin_PROGRAMS = gdm-dmx-reconnect-proxy
+endif
+
EXTRA_PROGRAMS = gdmaskpass gdmopen
gdmaskpass_SOURCES = \
@@ -47,3 +51,15 @@ gdmtranslate_LDADD = \
#gdmmktemp_LDADD = \
# $(INTLLIBS)
+
+if DMX_SUPPORT
+gdm_dmx_reconnect_proxy_SOURCES = \
+ gdm-dmx-reconnect-proxy.c
+
+gdm_dmx_reconnect_proxy_LDADD = \
+ $(GLIB_LIBS) \
+ $(X_EXTRA_LIBS) \
+ $(X_LIBS) \
+ -lX11 \
+ $(DMX_LIBS)
+endif