summaryrefslogtreecommitdiff
path: root/utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
index 992ba6cf..4772014c 100644
--- a/utils/Makefile.am
+++ b/utils/Makefile.am
@@ -7,6 +7,8 @@ AM_CPPFLAGS = \
-I$(top_builddir) \
-I$(top_srcdir)/common \
-I$(top_builddir)/common \
+ -DDATADIR=\"$(datadir)\" \
+ -DGDMCONFDIR=\"$(gdmconfdir)\" \
-DLOCALSTATEDIR=\""$(localstatedir)"\" \
-DGDM_SCREENSHOT_DIR=\""$(GDM_SCREENSHOT_DIR)"\"\
-DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
@@ -29,8 +31,20 @@ bin_PROGRAMS = \
gdm-screenshot \
$(NULL)
-gdmflexiserver_SOURCES = \
- gdmflexiserver.c \
+libexec_PROGRAMS = \
+ gdm-x-session \
+ $(NULL)
+
+gdm_x_session_LDADD = \
+ $(top_builddir)/common/libgdmcommon.la \
+ $(GTK_LIBS) \
+ $(COMMON_LIBS) \
+ $(SYSTEMD_LIBS) \
+ $(XLIB_LIBS) \
+ $(NULL)
+
+gdm_x_session_SOURCES = \
+ gdm-x-session.c \
$(NULL)
gdmflexiserver_LDADD = \