summaryrefslogtreecommitdiff
path: root/src/navigation/poi-cam/CMakeLists.txt
diff options
context:
space:
mode:
author <philippe colliot>2015-08-04 17:54:50 +0200
committer <philippe colliot>2015-08-04 17:54:50 +0200
commitf0d502c1548dc8cc0805a0a72f74e46d821c0a9e (patch)
treed395a1e6c079a18e871fc97c85ac5e53efe4b7c5 /src/navigation/poi-cam/CMakeLists.txt
parent86c047d1c415e506069e222f621e8c13735f9c20 (diff)
downloadpoi-service-f0d502c1548dc8cc0805a0a72f74e46d821c0a9e.tar.gz
Fix an issue with the former POC of POI search
Diffstat (limited to 'src/navigation/poi-cam/CMakeLists.txt')
-rw-r--r--src/navigation/poi-cam/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/navigation/poi-cam/CMakeLists.txt b/src/navigation/poi-cam/CMakeLists.txt
index 72e379e..250dfca 100644
--- a/src/navigation/poi-cam/CMakeLists.txt
+++ b/src/navigation/poi-cam/CMakeLists.txt
@@ -51,6 +51,10 @@ include_directories(${NAVIT_CONFIG_H_DIR}) # this one contains config.h that is
include_directories(${DBUS_GENERATED_INCLUDE_DIR}/poi-service)
+if(${YOCTO_CONFIG})
+ include_directories(${STAGING_INCDIR}/navit)
+endif()
+
set(PLUGIN_LDFLAGS ${DBUS_CPP_LDFLAGS} ${DBUS_CPP_GLIB_LDFLAGS} ${GLIB_LDFLAGS})
set(PLUGIN_LIBRARIES ${DBUS_CPP_LIBRARY_DIRS} ${GLIB_LIBRARY_DIRS} ${DBUS_CPP_GLIB_LIBRARY_DIRS})