summaryrefslogtreecommitdiff
path: root/enhanced-position-service/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'enhanced-position-service/CMakeLists.txt')
-rw-r--r--enhanced-position-service/CMakeLists.txt15
1 files changed, 6 insertions, 9 deletions
diff --git a/enhanced-position-service/CMakeLists.txt b/enhanced-position-service/CMakeLists.txt
index 9cb036c..60a2f9e 100644
--- a/enhanced-position-service/CMakeLists.txt
+++ b/enhanced-position-service/CMakeLists.txt
@@ -4,24 +4,23 @@
#
# Component Name: EnhancedPositionService
#
-# Author: Thomas Bader
+# Author: Marco Residori
#
-# Copyright (C) 2012, BMW Car IT GmbH
+# Copyright (C) 2014, XS Embedded GmbH
#
# License:
# This Source Code Form is subject to the terms of the
# Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with
# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
#
-# List of changes:
-#
-# 15/6/2014, Philippe Colliot, migrate to Qt5
-#
# @licence end@
###########################################################################
-cmake_minimum_required(VERSION 2.8.11)
project(enhanced-position-service)
+cmake_minimum_required(VERSION 2.6.0)
+
+option(WITH_DLT
+ "Enable DLT logging" OFF)
message(STATUS)
message(STATUS "---------------------------------------------------------")
@@ -42,8 +41,6 @@ if(WITH_REPLAYER)
set(sensors-service_LIBRARIES "sensors-service-use-replayer")
endif()
-set(QT_USE_QTDBUS TRUE)
-
include_directories(api src test ${gnss-service_INCLUDE_DIRS} ${sensors-service_INCLUDE_DIRS})
add_subdirectory(src)