summaryrefslogtreecommitdiff
path: root/gnss-service/test/compliance-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnss-service/test/compliance-test/CMakeLists.txt')
-rw-r--r--gnss-service/test/compliance-test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnss-service/test/compliance-test/CMakeLists.txt b/gnss-service/test/compliance-test/CMakeLists.txt
index 51da891..416eb75 100644
--- a/gnss-service/test/compliance-test/CMakeLists.txt
+++ b/gnss-service/test/compliance-test/CMakeLists.txt
@@ -13,6 +13,9 @@
# Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with
# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
#
+# Update (2014/12/02) : Philippe Colliot <philippe.colliot@mpsa.com>,
+# PSA Peugeot Citroen
+# - introduce debug flag to disable verbosity
# @licence end@
###########################################################################
@@ -20,6 +23,7 @@ message(STATUS "GNSS-SERVICE-COMPLIANCE-TEST")
message( STATUS "WITH_DLT = ${WITH_DLT}")
message( STATUS "WITH_GPSD = ${WITH_GPSD}")
message( STATUS "WITH_REPLAYER = ${WITH_REPLAYER}")
+message(STATUS "WITH_DEBUG = ${WITH_DEBUG}")
include_directories("${PROJECT_SOURCE_DIR}/api")
include_directories("${PROJECT_SOURCE_DIR}/src")
@@ -47,5 +51,9 @@ if(WITH_DLT)
set(LIBRARIES ${LIBRARIES} ${DLT_LIBRARIES})
endif()
+if(WITH_DEBUG)
+ add_definitions("-DDEBUG_ENABLED=1")
+endif()
+
target_link_libraries(gnss-service-compliance-test ${LIBRARIES})