summaryrefslogtreecommitdiff
path: root/log-replayer/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'log-replayer/test/CMakeLists.txt')
-rw-r--r--log-replayer/test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/log-replayer/test/CMakeLists.txt b/log-replayer/test/CMakeLists.txt
index eab70a9..a0cb59c 100644
--- a/log-replayer/test/CMakeLists.txt
+++ b/log-replayer/test/CMakeLists.txt
@@ -13,11 +13,15 @@
# Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with
# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
#
+# Update (2014/12/02) : Philippe Colliot <philippe.colliot@mpsa.com>,
+# PSA Peugeot Citroen
+# - introduce debug flag to disable verbosity
# @licence end@
###########################################################################
message(STATUS "TEST-LOG-REPLAYER")
message(STATUS "WITH_DLT = ${WITH_DLT}")
+message(STATUS "WITH_DEBUG = ${WITH_DEBUG}")
include_directories("${PROJECT_SOURCE_DIR}/src")
@@ -35,6 +39,10 @@ if(WITH_DLT)
set(LIBRARIES ${LIBRARIES} ${DLT_LIBRARIES})
endif()
+if(WITH_DEBUG)
+ add_definitions("-DDEBUG_ENABLED=1")
+endif()
+
target_link_libraries(test-log-replayer ${LIBRARIES})