summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLutz Bichler <Lutz.Bichler@bmw.de>2014-07-04 09:11:30 +0200
committerLutz Bichler <Lutz.Bichler@bmw.de>2014-07-04 09:11:30 +0200
commit2625b85fce07a8dead3545fc9172c36d251aa52f (patch)
tree3365fe13fdcdca3956043ce16522e1cdb603c948 /CMakeLists.txt
parent6f4727f59fedaa9065eca23f1072c8ea286a0474 (diff)
downloadvSomeIP-2625b85fce07a8dead3545fc9172c36d251aa52f.tar.gz
Included exportmap to explicitely specify the exported symbols.
Changed the design of the service discovery: the service discovery is now an extension to the routing manager implementation and thus lives in the same thread. The change was done as the routing manager implementation is the only component that knows about IP endpoints and transferring this information to the proxies just to be able to combine service discovery with a routing manager proxy is not feasible.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 24ea08f..29a7843 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -44,7 +44,7 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
set(DL_LIBRARY "")
endif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
-set (CMAKE_CXX_FLAGS "-D${OS} -DUSE_VSOMEIP_STATISTICS -DBOOST_LOG_DYN_LINK -g -std=c++0x -O0 -Wno-deprecated-register")
+set (CMAKE_CXX_FLAGS "-D${OS} -DUSE_VSOMEIP_STATISTICS -DBOOST_LOG_DYN_LINK -g -std=c++0x -O0 -Wno-deprecated-register -Wl,-export-dynamic -Wl,--version-script=../exportmap")
include_directories(
"interface"
)