summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJürgen Gehring <Juergen.Gehring@bmw.de>2016-11-04 09:26:06 -0700
committerJürgen Gehring <Juergen.Gehring@bmw.de>2016-11-04 09:26:06 -0700
commit30b6688d9f77d40352cc3cec99052e0946a8affc (patch)
tree52d7f9332f709917bb287db61505000e18eeeefd /CMakeLists.txt
parent7bb933404f4ee0be3add0c506b53e1c1f7274869 (diff)
downloadvSomeIP-30b6688d9f77d40352cc3cec99052e0946a8affc.tar.gz
vSomeIP 2.5.02.5.0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt33
1 files changed, 27 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 21967a6..1b0fd39 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,8 +7,8 @@ cmake_minimum_required (VERSION 2.8.12)
project (vsomeip)
set (VSOMEIP_MAJOR_VERSION 2)
-set (VSOMEIP_MINOR_VERSION 4)
-set (VSOMEIP_PATCH_VERSION 3)
+set (VSOMEIP_MINOR_VERSION 5)
+set (VSOMEIP_PATCH_VERSION 0)
set (VSOMEIP_VERSION ${VSOMEIP_MAJOR_VERSION}.${VSOMEIP_MINOR_VERSION}.${VSOMEIP_PATCH_VERSION})
set (PACKAGE_VERSION ${VSOMEIP_VERSION}) # Used in documentatin/doxygen.in
set (CMAKE_VERBOSE_MAKEFILE off)
@@ -115,7 +115,6 @@ link_directories(
# Base library
file(GLOB vsomeip_SRC
- "implementation/configuration/src/*.cpp"
"implementation/endpoints/src/*.cpp"
"implementation/logging/src/*.cpp"
"implementation/tracing/src/*.cpp"
@@ -130,7 +129,7 @@ add_definitions(-DVSOMEIP_VERSION="${VSOMEIP_VERSION}")
if (MSVC)
message("using MSVC Compiler")
- add_definitions(-DVSOMEIP_DLL_COMPILATION)
+ # add_definitions(-DVSOMEIP_DLL_COMPILATION) now it is controlled per target
SET(BOOST_WINDOWS_VERSION "0x600" CACHE STRING "Set the same Version as the Version with which Boost was built, otherwise there will be errors. (normaly 0x600 is for Windows 7 and 0x501 is for Windows XP)")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -D_WINSOCK_DEPRECATED_NO_WARNINGS -D_WIN32_WINNT=${BOOST_WINDOWS_VERSION} -DWIN32 -DUSE_VSOMEIP_STATISTICS -DCOMMONAPI_INTERNAL_COMPILATION -DBOOST_LOG_DYN_LINK -DBOOST_ASIO_DISABLE_IOCP /EHsc")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_CRT_SECURE_NO_WARNINGS -D_SCL_SECURE_NO_WARNINGS -D_WINSOCK_DEPRECATED_NO_WARNINGS -D_WIN32_WINNT=${BOOST_WINDOWS_VERSION} -DWIN32 -DUSE_VSOMEIP_STATISTICS -DCOMMONAPI_INTERNAL_COMPILATION -DBOOST_LOG_DYN_LINK -DBOOST_ASIO_DISABLE_IOCP /EHsc")
@@ -152,6 +151,16 @@ set_target_properties (vsomeip PROPERTIES VERSION ${VSOMEIP_VERSION} SOVERSION $
# the build.
target_link_libraries(vsomeip PRIVATE ${Boost_LIBRARIES} ${USE_RT} ${DL_LIBRARY} ${DLT_LIBRARIES} ${SystemD_LIBRARIES} )
+# Configuration library
+file(GLOB vsomeip-cfg_SRC
+ "implementation/configuration/src/*.cpp"
+)
+list(SORT vsomeip-cfg_SRC)
+
+add_library(vsomeip-cfg SHARED ${vsomeip-cfg_SRC})
+set_target_properties (vsomeip-cfg PROPERTIES VERSION ${VSOMEIP_VERSION} SOVERSION ${VSOMEIP_MAJOR_VERSION})
+target_link_libraries(vsomeip-cfg vsomeip ${Boost_LIBRARIES} ${USE_RT} ${DL_LIBRARY} ${SystemD_LIBRARIES})
+
file(GLOB vsomeip-sd_SRC
"implementation/service_discovery/src/*.cpp"
)
@@ -161,6 +170,12 @@ add_library(vsomeip-sd SHARED ${vsomeip-sd_SRC})
set_target_properties (vsomeip-sd PROPERTIES VERSION ${VSOMEIP_VERSION} SOVERSION ${VSOMEIP_MAJOR_VERSION})
target_link_libraries(vsomeip-sd vsomeip ${Boost_LIBRARIES} ${USE_RT} ${DL_LIBRARY} ${SystemD_LIBRARIES})
+if (MSVC)
+ set_target_properties(vsomeip-cfg PROPERTIES COMPILE_DEFINITIONS "VSOMEIP_DLL_COMPILATION_CONFIG")
+ set_target_properties(vsomeip-sd PROPERTIES COMPILE_DEFINITIONS "VSOMEIP_DLL_COMPILATION")
+ set_target_properties(vsomeip PROPERTIES COMPILE_DEFINITIONS "VSOMEIP_DLL_COMPILATION")
+endif()
+
# Configuration files
set(EXAMPLE_CONFIG_FILES
@@ -212,6 +227,12 @@ install (
)
install (
+ TARGETS vsomeip-cfg
+ LIBRARY DESTINATION "${INSTALL_LIB_DIR}" COMPONENT shlib
+ RUNTIME DESTINATION "${INSTALL_BIN_DIR}" COMPONENT bin
+)
+
+install (
TARGETS vsomeip-sd
LIBRARY DESTINATION "${INSTALL_LIB_DIR}" COMPONENT shlib
RUNTIME DESTINATION "${INSTALL_BIN_DIR}" COMPONENT bin
@@ -321,8 +342,8 @@ else()
COMMAND asciidoc
-a version=${VSOMEIP_VERSION}
-b html
- -o documentation/README.html
- ${PROJECT_BINARY_DIR}/../README)
+ -o documentation/vsomeipUserGuide.html
+ ${PROJECT_BINARY_DIR}/../documentation/vsomeipUserGuide)
endif()
##############################################################################