summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLutz Bichler <Lutz.Bichler@bmw.de>2014-07-07 07:48:22 +0200
committerLutz Bichler <Lutz.Bichler@bmw.de>2014-07-07 07:48:22 +0200
commitc105ac6a4e0ce99e0ed1906b3342b7fb317f14f5 (patch)
treee71d2879ada1adea4304edced069957b2fc14eb7 /CMakeLists.txt
parent47e776a13396293ed6d8b49f8b991c40c8596337 (diff)
downloadvSomeIP-c105ac6a4e0ce99e0ed1906b3342b7fb317f14f5.tar.gz
Added some initial SD code (without any functionality yet)
Renamed exportmap to reflect the fact that it is gcc-specific. Adapted cmake-file to use the export map for gcc (Linux) only. Adapted name of IP-option implementations Commented recursive lambda function as clang complains about it not being initialized and might be right.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 84c246a..856df01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,7 @@ endforeach ()
if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
set(OS "LINUX")
set(DL_LIBRARY "dl")
- set(EXPORTSYMBOLS "-Wl,-export-dynamic -Wl,--version-script=../exportmap")
+ set(EXPORTSYMBOLS "-Wl,-export-dynamic -Wl,--version-script=../exportmap.gcc")
set(NO_DEPRECATED "")
endif (${CMAKE_SYSTEM_NAME} MATCHES "Linux")