summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLutz Bichler <Lutz.Bichler@bmw.de>2014-08-04 16:19:33 +0200
committerLutz Bichler <Lutz.Bichler@bmw.de>2014-08-04 16:19:33 +0200
commitd3644b3edc8b15ace244724bc50e4fbfbf9601ec (patch)
treed050b187022414c188fac9ea8bfdeb22007996e5 /CMakeLists.txt
parentdeebe9fbce59a421f85635a01cbaf8b66b742665 (diff)
downloadvSomeIP-d3644b3edc8b15ace244724bc50e4fbfbf9601ec.tar.gz
Implemented notification events (tested over IP / untested internally).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1df6f11..880cccb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,7 +47,7 @@ if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
set(DL_LIBRARY "")
set(EXPORTSYMBOLS "")
set(NO_DEPRECATED "-Wno-deprecated")
- set(OPTIMIZE "-Os")
+ set(OPTIMIZE "")
endif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
# Compiler settings
@@ -83,11 +83,17 @@ add_library(vsomeip-sd SHARED ${vsomeip-sd_SRC})
target_link_libraries(vsomeip-sd vsomeip ${Boost_LIBRARIES} rt ${DL_LIBRARY})
# Examples
-add_executable(client-sample examples/client-sample.cpp)
-target_link_libraries(client-sample vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
+add_executable(request-sample examples/request-sample.cpp)
+target_link_libraries(request-sample vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
-add_executable(service-sample examples/service-sample.cpp)
-target_link_libraries(service-sample vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
+add_executable(response-sample examples/response-sample.cpp)
+target_link_libraries(response-sample vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
+
+add_executable(subscribe-sample examples/subscribe-sample.cpp)
+target_link_libraries(subscribe-sample vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
+
+add_executable(notify-sample examples/notify-sample.cpp)
+target_link_libraries(notify-sample vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
# Test
add_executable(configuration-test test/configuration-test.cpp)