summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLutz Bichler <Lutz.Bichler@bmw.de>2014-07-15 15:25:39 +0200
committerLutz Bichler <Lutz.Bichler@bmw.de>2014-07-15 15:25:39 +0200
commite9daa9eaecf84aa69b7c643cc3820eb8f295dc7b (patch)
treea4637f5c8cb9af8c244a43e9163fc843080d61bf /CMakeLists.txt
parent66cb571f4858df44759e5af8201a3542bcd510be (diff)
downloadvSomeIP-e9daa9eaecf84aa69b7c643cc3820eb8f295dc7b.tar.gz
Re-enabled and adapted implementation of "Magic Cookies".
Created a test program (magic-cookies-test-client) that sends messages with correct (session 1, 3, 6, 7, B, C, D, F) and incorrect payload (session 2, 4, 5, 8, 9, A, E). It is expected that you see responses for the messages with the correct payload while the messages with the incorrect payload have been ignored. The test program needs to be run with VSOMEIP_APPLICATION_NAME=client-sample and VSOMEIP_CONFIGURATION_FILE=vsomeip-magic-cookies-client.xml. The corresponding service (service-sample) must be run with VSOMEIP_APPLICATION_NAME=service-sample and VSOMEIP_CONFIGURATION_FILE=vsomeip-magic-cookies-service.xml. Please note that the IP configuration must be adapted to the local setting.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebdb847..6fa407c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -78,16 +78,20 @@ file(GLOB vsomeip-sd_SRC
add_library(vsomeip-sd SHARED ${vsomeip-sd_SRC})
target_link_libraries(vsomeip-sd vsomeip ${Boost_LIBRARIES} rt ${DL_LIBRARY})
-# Executables
-add_executable(configuration-test test/configuration-test.cpp)
-target_link_libraries(configuration-test vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
-
+# Examples
add_executable(client-sample examples/client-sample.cpp)
target_link_libraries(client-sample vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
add_executable(service-sample examples/service-sample.cpp)
target_link_libraries(service-sample vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
+# Test
+add_executable(configuration-test test/configuration-test.cpp)
+target_link_libraries(configuration-test vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
+
+add_executable(magic-cookies-test-client test/magic-cookies-test-client.cpp)
+target_link_libraries(magic-cookies-test-client vsomeip ${Boost_LIBRARIES} ${DL_LIBRARY})
+
###################################################################################################
file (GLOB_RECURSE vsomeip_INCLUDE "interface/*.hpp")