summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLutz Bichler <Lutz.Bichler@bmw.de>2014-09-24 12:16:49 +0200
committerLutz Bichler <Lutz.Bichler@bmw.de>2014-09-24 12:16:49 +0200
commitf141e95605ac539d1d091d14b5308c10df7fd859 (patch)
tree874906192c1093721e2a54c3bebc2973a55299a5 /CMakeLists.txt
parentbcb5ab22e31020b365ae5c6916aef7f7bca9610e (diff)
downloadvSomeIP-f141e95605ac539d1d091d14b5308c10df7fd859.tar.gz
[PATCH 2/8] CMakeLists.txt: add windows-style line breaks to some lines
The CMakeLists.txt had in most lines CRLF line endings (as currently most files in this repository), but a few lines were ending without CRLF. This commit was produced by opening the file in the jEdit editor, and saving it without any textual modification. Afterwards, I also checked that the command 'unix2dos CMakeLists.txt' produces exactly the same changes in the CMakeLists.txt. Signed-off-by: Lukas Bulwahn, BMW Car IT GmbH <Lukas.Bulwahn@bmw.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3116706..e93f405 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,15 +37,15 @@ endforeach ()
if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
set(OS "LINUX")
set(DL_LIBRARY "dl")
- set(EXPORTSYMBOLS "-Wl,-export-dynamic -Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exportmap.gcc")
+ set(EXPORTSYMBOLS "-Wl,-export-dynamic -Wl,--version-script=${CMAKE_CURRENT_SOURCE_DIR}/exportmap.gcc")
set(NO_DEPRECATED "")
- set(OPTIMIZE "")
+ set(OPTIMIZE "")
endif (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
set(OS "FREEBSD")
set(DL_LIBRARY "")
- set(EXPORTSYMBOLS "")
+ set(EXPORTSYMBOLS "")
set(NO_DEPRECATED "-Wno-deprecated")
set(OPTIMIZE "")
endif (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
@@ -109,7 +109,7 @@ file (GLOB_RECURSE vsomeip_INCLUDE "interface/*.hpp")
set_target_properties (vsomeip PROPERTIES PUBLIC_HEADER "${vsomeip_INCLUDE}")
install (
- TARGETS vsomeip
+ TARGETS vsomeip
# IMPORTANT: Add the vsomeip library to the "export-set"
EXPORT vsomeipTargets
RUNTIME DESTINATION "${INSTALL_BIN_DIR}" COMPONENT bin