summaryrefslogtreecommitdiff
path: root/ivi-layermanagement-examples/layer-add-surfaces/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ivi-layermanagement-examples/layer-add-surfaces/CMakeLists.txt')
-rw-r--r--ivi-layermanagement-examples/layer-add-surfaces/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/ivi-layermanagement-examples/layer-add-surfaces/CMakeLists.txt b/ivi-layermanagement-examples/layer-add-surfaces/CMakeLists.txt
new file mode 100644
index 0000000..97e1cf0
--- /dev/null
+++ b/ivi-layermanagement-examples/layer-add-surfaces/CMakeLists.txt
@@ -0,0 +1,49 @@
+############################################################################
+#
+# Copyright 2012 BMW Car IT GmbH
+#
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+############################################################################
+
+project (layer-add-surfaces)
+
+include_directories(
+ include
+ "${CMAKE_SOURCE_DIR}/ivi-layermanagement-api/ilmCommon/include"
+ "${CMAKE_SOURCE_DIR}/ivi-layermanagement-api/ilmClient/include"
+ "${CMAKE_SOURCE_DIR}/ivi-layermanagement-api/ilmControl/include"
+ "${CMAKE_SOURCE_DIR}/ivi-input-api/ilmInput/include"
+ ${WAYLAND_CLIENT_INCLUDE_DIR}
+)
+
+link_directories(
+ ${WAYLAND_CLIENT_LIBRARY_DIRS}
+)
+
+SET(LIBS
+ ilmControl
+)
+
+SET(SRC_FILES
+ src/layer-add-surfaces.c
+)
+
+add_executable(${PROJECT_NAME} ${SRC_FILES})
+
+add_dependencies(${PROJECT_NAME} ${LIBS})
+
+target_link_libraries(${PROJECT_NAME} ${LIBS})
+
+install (TARGETS ${PROJECT_NAME} DESTINATION bin)